CVE catalog

CVE-2014-2538

ruby-rack-ssl: CVE-2014-2538

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.19% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-rack-sslsid1.4.1-4fixed
Debianruby-rack-sslforky1.4.1-4fixed
Debianruby-rack-ssltrixie1.4.1-2.1fixed
Debianruby-rack-sslbookworm1.4.1-2.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-rack-sslsourcesid1.3.2-4lowNot reported[742186]
Debianruby-rack-sslsourceforky1.3.2-4lowNot reported[742186]
Debianruby-rack-sslsourcetrixie1.3.2-4lowNot reported[742186]
Debianruby-rack-sslsourcebookworm1.3.2-4lowNot reported[742186]

[Debian bug #742186]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.4.1-2.1 · all · bookworm

      Fixed · Fixed: 1.3.2-4

      dsa · ruby-rack-ssl · debian · bookworm; dsa · ruby-rack-ssl · debian · 12

    • 1.4.1-2.1 · all · bookworm

      Fixed · Fixed: 1.3.2-4

      dsa · ruby-rack-ssl · debian · bookworm; dsa · ruby-rack-ssl · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.4.1-2.1 · all · trixie

      Fixed · Fixed: 1.3.2-4

      dsa · ruby-rack-ssl · debian · 13

    • 1.4.1-2.1 · all · trixie

      Fixed · Fixed: 1.3.2-4

      dsa · ruby-rack-ssl · debian · 13

Observed:

References