CVE catalog

CVE-2014-2570

php-font-lib: CVE-2014-2570

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
2.14% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in www/make_subset.php in PHP Font Lib before 0.3.1 allows remote attackers to inject arbitrary web script or HTML via the name parameter.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphp-font-libsid1.0.2-1fixed
Debianphp-font-libforky1.0.2-1fixed
Debianphp-font-libtrixie1.0.1-1fixed
Debianphp-font-libbookworm0.5.4+dfsg-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphp-font-libsourcesid0.3.1+dfsg-2unimportantNot reportedNot reported
Debianphp-font-libsourceforky0.3.1+dfsg-2unimportantNot reportedNot reported
Debianphp-font-libsourcetrixie0.3.1+dfsg-2unimportantNot reportedNot reported
Debianphp-font-libsourcebookworm0.3.1+dfsg-2unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 0.5.4+dfsg-2 · all · bookworm

      Fixed · Fixed: 0.3.1+dfsg-2

      dsa · php-font-lib · debian · bookworm; dsa · php-font-lib · debian · 12

    • 0.5.4+dfsg-2 · all · bookworm

      Fixed · Fixed: 0.3.1+dfsg-2

      dsa · php-font-lib · debian · bookworm; dsa · php-font-lib · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.0.1-1 · all · trixie

      Fixed · Fixed: 0.3.1+dfsg-2

      dsa · php-font-lib · debian · 13

    • 1.0.1-1 · all · trixie

      Fixed · Fixed: 0.3.1+dfsg-2

      dsa · php-font-lib · debian · 13

Observed:

References