CVE catalog

CVE-2014-2655

postfixadmin: CVE-2014-2655

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.88% · Oct 25, 2026

SQL injection vulnerability in the gen_show_status function in functions.inc.php in Postfix Admin (aka postfixadmin) before 2.3.7 allows remote authenticated users to execute arbitrary SQL commands via a new alias.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpostfixadminsid4.0.5+ds+~cs20.241.5-1fixed
Debianpostfixadminforky4.0.5+ds+~cs20.241.5-1fixed
Debianpostfixadmintrixie3.3.15+ds-2fixed
Debianpostfixadminbookworm3.3.13-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpostfixadminsourcesid2.3.5-3not yet assignedNot reportedNot reported
Debianpostfixadminsourceforky2.3.5-3not yet assignedNot reportedNot reported
Debianpostfixadminsourcetrixie2.3.5-3not yet assignedNot reportedNot reported
Debianpostfixadminsourcebookworm2.3.5-3not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 3.3.13-1 · all · bookworm

      Fixed · Fixed: 2.3.5-3

      dsa · postfixadmin · debian · bookworm; dsa · postfixadmin · debian · 12

    • 3.3.13-1 · all · bookworm

      Fixed · Fixed: 2.3.5-3

      dsa · postfixadmin · debian · bookworm; dsa · postfixadmin · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 3.3.15+ds-2 · all · trixie

      Fixed · Fixed: 2.3.5-3

      dsa · postfixadmin · debian · 13

    • 3.3.15+ds-2 · all · trixie

      Fixed · Fixed: 2.3.5-3

      dsa · postfixadmin · debian · 13

Observed:

References