CVE catalog

CVE-2014-2686

ansible: CVE-2014-2686

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.19% · Oct 27, 2026

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianansiblesid14.4.0+dfsg-1fixed
Debianansibleforky14.0.0+dfsg-1fixed
Debianansibletrixie12.0.0+dfsg-0+deb13u1fixed
Debianansiblebookworm7.7.0+dfsg-3+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianansiblesourcesid1.5.4+dfsg-1not yet assignedNot reportedNot reported
Debianansiblesourceforky1.5.4+dfsg-1not yet assignedNot reportedNot reported
Debianansiblesourcetrixie1.5.4+dfsg-1not yet assignedNot reportedNot reported
Debianansiblesourcebookworm1.5.4+dfsg-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ansible]Fixed
    Details (2)
    • 7.7.0+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 1.5.4+dfsg-1

      dsa · ansible · debian · bookworm; dsa · ansible · debian · 12

    • 7.7.0+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 1.5.4+dfsg-1

      dsa · ansible · debian · bookworm; dsa · ansible · debian · 12

[Debian 13 (Trixie)]

  • [ansible]Fixed
    Details (2)
    • 12.0.0+dfsg-0+deb13u1 · all · trixie

      Fixed · Fixed: 1.5.4+dfsg-1

      dsa · ansible · debian · 13

    • 12.0.0+dfsg-0+deb13u1 · all · trixie

      Fixed · Fixed: 1.5.4+dfsg-1

      dsa · ansible · debian · 13

Observed:

References