CVE catalog

CVE-2014-4657

ansible: CVE-2014-4657

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
4.43% · Oct 25, 2026

The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianansiblesid14.4.0+dfsg-1fixed
Debianansibleforky14.0.0+dfsg-1fixed
Debianansibletrixie12.0.0+dfsg-0+deb13u1fixed
Debianansiblebookworm7.7.0+dfsg-3+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianansiblesourcesid1.5.5+dfsg-1not yet assignedNot reportedNot reported
Debianansiblesourceforky1.5.5+dfsg-1not yet assignedNot reportedNot reported
Debianansiblesourcetrixie1.5.5+dfsg-1not yet assignedNot reportedNot reported
Debianansiblesourcebookworm1.5.5+dfsg-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ansible]Fixed
    Details (2)
    • 7.7.0+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 1.5.5+dfsg-1

      dsa · ansible · debian · bookworm; dsa · ansible · debian · 12

    • 7.7.0+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 1.5.5+dfsg-1

      dsa · ansible · debian · bookworm; dsa · ansible · debian · 12

[Debian 13 (Trixie)]

  • [ansible]Fixed
    Details (2)
    • 12.0.0+dfsg-0+deb13u1 · all · trixie

      Fixed · Fixed: 1.5.5+dfsg-1

      dsa · ansible · debian · 13

    • 12.0.0+dfsg-0+deb13u1 · all · trixie

      Fixed · Fixed: 1.5.5+dfsg-1

      dsa · ansible · debian · 13

Observed:

References