
CVE catalog
CVE-2014-4975
Security update for ruby2.1
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 3.46% · Oct 25, 2026
Off-by-one error in the encodes function in pack.c in Ruby 1.9.3 and earlier, and 2.x through 2.1.2, when using certain format string specifiers, allows context-dependent attackers to cause a denial of service (segmentation fault) via vectors that trigger a stack-based buffer overflow.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.194-8.1ubuntu2 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.448-1ubuntu1 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.448-1ubuntu2 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-1ubuntu1 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-1ubuntu2 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-2ubuntu1 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-2ubuntu1.1 | fixed |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.299-2 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.343-1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.343-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.353-1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.353-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2.1 | fixed |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.194-8.1ubuntu2 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.448-1ubuntu1 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.448-1ubuntu2 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-1ubuntu1 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-1ubuntu2 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-2ubuntu1 | vulnerable |
| Ubuntu | ruby1.9.1 | 14.04 | 1.9.3.484-2ubuntu1.1 | fixed |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.299-2 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.343-1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.343-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.353-1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.353-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2.1 | fixed |
| Debian | ruby1.9.1 | 7 | 1.9.3.194-8.1 | vulnerable |
| Debian | ruby1.9.1 | 7 | 1.9.3.194-8.1+deb7u1 | vulnerable |
| Debian | ruby1.9.1 | 7 | 1.9.3.194-8.1+deb7u2 | vulnerable |
| Debian | ruby1.9.1 | 7 | 1.9.3.194-8.1+deb7u3 | fixed |
| Debian | ruby1.9.1 | 6.0 | 1.9.2.0-2 | vulnerable |
| Debian | ruby1.9.1 | 6.0 | 1.9.2.0-2+armhf | vulnerable |
| Debian | ruby1.9.1 | 6.0 | 1.9.2.0-2+deb6u3 | fixed |
| Suse | ruby2.1 | linux enterprise desktop 12 sp1 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise desktop 12 sp2 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise server for raspberry pi 12 sp2 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise software development kit 12 sp1 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise software development kit 12 sp2 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise server 12 sp1 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise server for sap applications 12 sp1 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise server 12 sp2 | 2.1.9-15.1 | fixed |
| Suse | ruby2.1 | linux enterprise server for sap applications 12 sp2 | 2.1.9-15.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Ubuntu | ruby1.9.1 | deb | 14.04 | 1.9.3.484-2ubuntu1.1 | Not reported | UBUNTU-CVE-2014-4975 | Not reported |
| Ubuntu | ruby2.0 | deb | 14.04 | 2.0.0.484-1ubuntu2.1 | Not reported | UBUNTU-CVE-2014-4975 | Not reported |
| Ubuntu | ruby1.9.1 | deb | 14.04 | 1.9.3.484-2ubuntu1.1 | Not reported | USN-2397-1 | Not reported |
| Ubuntu | ruby2.0 | deb | 14.04 | 2.0.0.484-1ubuntu2.1 | Not reported | USN-2397-1 | Not reported |
| Debian | ruby1.9.1 | deb | 7 | 1.9.3.194-8.1+deb7u3 | Not reported | DSA-3157-1 | Not reported |
| Debian | ruby1.9.1 | deb | 6.0 | 1.9.2.0-2+deb6u3 | Not reported | DLA-200-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise desktop 12 sp1 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise desktop 12 sp2 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise server for raspberry pi 12 sp2 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise software development kit 12 sp1 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise software development kit 12 sp2 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise server 12 sp1 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise server for sap applications 12 sp1 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise server 12 sp2 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
| Suse | ruby2.1 | rpm | linux enterprise server for sap applications 12 sp2 | 2.1.9-15.1 | Not reported | SUSE-SU-2017:1067-1 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2014_1912.json]
- [https://osv.dev/vulnerability/DLA-200-1]
- [https://osv.dev/vulnerability/DSA-3157-1]
- [https://osv.dev/vulnerability/SUSE-SU-2017:1067-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2014-4975]
- [https://osv.dev/vulnerability/USN-2397-1]
- [https://security.access.redhat.com/data/csaf/v2/vex/2014/cve-2014-4975.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]