CVE catalog

CVE-2014-6393

node-express: CVE-2014-6393

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
1.14% · Oct 25, 2026

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-expresssid5.2.1+~cs12.3.9-1fixed
Debiannode-expressforky5.2.1+~cs12.3.9-1fixed
Debiannode-expresstrixie4.21.2+~cs8.36.27-2fixed
Debiannode-expressbookworm4.18.2+~4.17.14-1fixed
Ubuntunode-expresspro4.1.1~dfsg-1vulnerable
Ubuntunode-expresspro4.1.1~dfsg-1ubuntu0.18.04.1~esm1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-expresssourcesid4.16.4-1unimportantNot reportedNot reported
Debiannode-expresssourceforky4.16.4-1unimportantNot reportedNot reported
Debiannode-expresssourcetrixie4.16.4-1unimportantNot reportedNot reported
Debiannode-expresssourcebookworm4.16.4-1unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 4.18.2+~4.17.14-1 · all · bookworm

      Fixed · Fixed: 4.16.4-1

      dsa · node-express · debian · bookworm; dsa · node-express · debian · 12

    • 4.18.2+~4.17.14-1 · all · bookworm

      Fixed · Fixed: 4.16.4-1

      dsa · node-express · debian · bookworm; dsa · node-express · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 4.21.2+~cs8.36.27-2 · all · trixie

      Fixed · Fixed: 4.16.4-1

      dsa · node-express · debian · 13

    • 4.21.2+~cs8.36.27-2 · all · trixie

      Fixed · Fixed: 4.16.4-1

      dsa · node-express · debian · 13

Observed:

References