CVE catalog

CVE-2014-7146

mantis - security update

[CVE catalog]

The XmlImportExport plugin in MantisBT 1.2.17 and earlier allows remote attackers to execute arbitrary PHP code via a crafted (1) description field or (2) issuelink attribute in an XML file, which is not properly handled when executing the preg_replace function with the e modifier. Red Hat Product Security has determined that this vulnerability does not affect any currently supported Red Hat product. This assessment may evolve based on further analysis and discovery. For more information about this vulnerability and the products it affects, please see the linked references. The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
50.56% · Oct 27, 2026

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Debian7mantis1.2.11-1.2UnknownSource applicability is not established[DSA-3120-1]
Debian7mantis1.2.11-1.2+deb7u1UnknownSource applicability is not established[DSA-3120-1]
Debian7mantis1.2.18-1UnknownSource applicability is not established[DSA-3120-1]
Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
Debian7mantis1.2.11-1.2UnknownSource applicability is not established[DSA-3120-1]
Debian7mantis1.2.11-1.2+deb7u1UnknownSource applicability is not established[DSA-3120-1]
Debian7mantis1.2.18-1UnknownSource applicability is not established[DSA-3120-1]
Original provider fields
{
  "package_releases": [],
  "fixed_versions": [],
  "distribution_packages": [
    {
      "name": "mantis",
      "distro": "debian",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.2.18-1"
            }
          ]
        }
      ],
      "release": "7",
      "versions": [
        "1.2.11-1.2",
        "1.2.11-1.2+deb7u1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/DSA-3120-1",
      "fixed_version": "1.2.18-1",
      "provider_source": "pypi",
      "provider_record_id": "DSA-3120-1",
      "provider_updated_at": "2026-03-09T01:22:14.978024Z",
      "applicability_unknown": true
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

Observed:

References