CVE catalog

CVE-2014-9637

patch: CVE-2014-9637

[CVE catalog]

Severity
Medium · CVSS 5.5CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
2.36% · Oct 25, 2026

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpatchsid2.8.1-1fixed
Debianpatchforky2.8.1-1fixed
Debianpatchtrixie2.8-2fixed
Debianpatchbookworm2.7.6-7fixed
Ubuntupatch14.042.7.1-3vulnerable
Ubuntupatch14.042.7.1-4vulnerable
Ubuntupatch14.042.7.1-4ubuntu1vulnerable
Ubuntupatch14.042.7.1-4ubuntu2vulnerable
Ubuntupatch14.042.7.1-4ubuntu2.3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpatchsourcesid2.7.1-7not yet assignedNot reportedNot reported
Debianpatchsourceforky2.7.1-7not yet assignedNot reportedNot reported
Debianpatchsourcetrixie2.7.1-7not yet assignedNot reportedNot reported
Debianpatchsourcebookworm2.7.1-7not yet assignedNot reportedNot reported
Ubuntupatchdeb14.042.7.1-4ubuntu2.3Not reportedUBUNTU-CVE-2014-9637Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [patch]Fixed
    Details (2)
    • 2.7.6-7 · amd64 · bookworm

      Fixed · Fixed: 2.7.1-7

      dsa · patch · debian · bookworm; dsa · patch · debian · 12

    • 2.7.6-7 · arm64 · bookworm

      Fixed · Fixed: 2.7.1-7

      dsa · patch · debian · bookworm; dsa · patch · debian · 12

[Debian 13 (Trixie)]

  • [patch]Fixed
    Details (2)
    • 2.8-2 · amd64 · trixie

      Fixed · Fixed: 2.7.1-7

      dsa · patch · debian · 13

    • 2.8-2 · arm64 · trixie

      Fixed · Fixed: 2.7.1-7

      dsa · patch · debian · 13

Observed:

References