CVE catalog

CVE-2015-0227

wss4j: CVE-2015-0227

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
7.54% · Oct 25, 2026

Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianwss4jsid1.6.19-4fixed
Debianwss4jforky1.6.19-4fixed
Debianwss4jtrixie1.6.19-4fixed
Debianwss4jbookworm1.6.19-3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianwss4jsourcesid1.6.15-2not yet assignedNot reported[777741]
Debianwss4jsourceforky1.6.15-2not yet assignedNot reported[777741]
Debianwss4jsourcetrixie1.6.15-2not yet assignedNot reported[777741]
Debianwss4jsourcebookworm1.6.15-2not yet assignedNot reported[777741]

[Debian bug #777741]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [wss4j]

    Details (2)
    • 1.6.19-3 · all · bookworm

      Fixed · Fixed: 1.6.15-2

      dsa · wss4j · debian · bookworm; dsa · wss4j · debian · 12

    • 1.6.19-3 · all · bookworm

      Fixed · Fixed: 1.6.15-2

      dsa · wss4j · debian · bookworm; dsa · wss4j · debian · 12

[Debian 13 (Trixie)]

  • Source package: [wss4j]

    Details (2)
    • 1.6.19-4 · all · trixie

      Fixed · Fixed: 1.6.15-2

      dsa · wss4j · debian · 13

    • 1.6.19-4 · all · trixie

      Fixed · Fixed: 1.6.15-2

      dsa · wss4j · debian · 13

Observed:

References