CVE catalog

CVE-2015-1029

puppet-module-puppetlabs-stdlib: CVE-2015-1029

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.65% · Oct 25, 2026

The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpuppet-module-puppetlabs-stdlibsid9.4.1-2fixed
Debianpuppet-module-puppetlabs-stdlibforky9.4.1-2fixed
Debianpuppet-module-puppetlabs-stdlibtrixie9.4.1-1fixed
Debianpuppet-module-puppetlabs-stdlibbookworm8.5.0-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpuppet-module-puppetlabs-stdlibsourcesid4.9.0-1not yet assignedNot reported[775535]
Debianpuppet-module-puppetlabs-stdlibsourceforky4.9.0-1not yet assignedNot reported[775535]
Debianpuppet-module-puppetlabs-stdlibsourcetrixie4.9.0-1not yet assignedNot reported[775535]
Debianpuppet-module-puppetlabs-stdlibsourcebookworm4.9.0-1not yet assignedNot reported[775535]

[Debian bug #775535]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 8.5.0-1 · all · bookworm

      Fixed · Fixed: 4.9.0-1

      dsa · puppet-module-puppetlabs-stdlib · debian · bookworm; dsa · puppet-module-puppetlabs-stdlib · debian · 12

    • 8.5.0-1 · all · bookworm

      Fixed · Fixed: 4.9.0-1

      dsa · puppet-module-puppetlabs-stdlib · debian · bookworm; dsa · puppet-module-puppetlabs-stdlib · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 9.4.1-1 · all · trixie

      Fixed · Fixed: 4.9.0-1

      dsa · puppet-module-puppetlabs-stdlib · debian · 13

    • 9.4.1-1 · all · trixie

      Fixed · Fixed: 4.9.0-1

      dsa · puppet-module-puppetlabs-stdlib · debian · 13

Observed:

References