CVE catalog

CVE-2015-1032

kiwix: CVE-2015-1032

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.89% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in Kiwix before 0.9.1, when using kiwix-serve, allows remote attackers to inject arbitrary web script or HTML via the pattern parameter to /search.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiankiwixsid2.4.1-2fixed
Debiankiwixforky2.4.1-2fixed
Debiankiwixtrixie2.4.1-1.1fixed
Debiankiwixbookworm2.3.0-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiankiwixsourcesid2.0.4-1not yet assignedNot reportedNot reported
Debiankiwixsourceforky2.0.4-1not yet assignedNot reportedNot reported
Debiankiwixsourcetrixie2.0.4-1not yet assignedNot reportedNot reported
Debiankiwixsourcebookworm2.0.4-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [kiwix]Fixed
    Details (2)
    • 2.3.0-1 · amd64 · bookworm

      Fixed · Fixed: 2.0.4-1

      dsa · kiwix · debian · bookworm; dsa · kiwix · debian · 12

    • 2.3.0-1 · arm64 · bookworm

      Fixed · Fixed: 2.0.4-1

      dsa · kiwix · debian · bookworm; dsa · kiwix · debian · 12

[Debian 13 (Trixie)]

  • [kiwix]Fixed
    Details (2)
    • 2.4.1-1.1 · arm64 · trixie

      Fixed · Fixed: 2.0.4-1

      dsa · kiwix · debian · 13

    • 2.4.1-1.1+b1 · amd64 · trixie

      Fixed · Fixed: 2.0.4-1

      dsa · kiwix · debian · 13

Observed:

References