CVE catalog

CVE-2015-20108

ruby-saml: CVE-2015-20108

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.33% · Oct 25, 2026

xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-samlbookworm1.13.0-1+deb12u1fixed
Debianruby-samlbookworm-security1.13.0-1+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-samlsourcebookworm1.0.0-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ruby-saml]Fixed
    Details (4)
    • 1.13.0-1+deb12u1 · all · bookworm

      Fixed · Fixed: 1.0.0-1

      dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12

    • 1.13.0-1+deb12u1 · all · bookworm

      Fixed · Fixed: 1.0.0-1

      dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12

    • 1.13.0-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.0.0-1

      dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12

    • 1.13.0-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.0.0-1

      dsa · ruby-saml · debian · bookworm; dsa · ruby-saml · debian · 12

Observed:

References