CVE catalog

CVE-2015-2793

ikiwiki: CVE-2015-2793

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.69% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianikiwikisid3.20260201-3fixed
Debianikiwikiforky3.20260201-3fixed
Debianikiwikitrixie3.20250501-1fixed
Debianikiwikibookworm3.20200202.3-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianikiwikisourcesid3.20141016.2not yet assignedNot reported[781483]
Debianikiwikisourceforky3.20141016.2not yet assignedNot reported[781483]
Debianikiwikisourcetrixie3.20141016.2not yet assignedNot reported[781483]
Debianikiwikisourcebookworm3.20141016.2not yet assignedNot reported[781483]

[Debian bug #781483]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ikiwiki]Fixed
    Details (2)
    • 3.20200202.3-1 · all · bookworm

      Fixed · Fixed: 3.20141016.2

      dsa · ikiwiki · debian · bookworm; dsa · ikiwiki · debian · 12

    • 3.20200202.3-1 · all · bookworm

      Fixed · Fixed: 3.20141016.2

      dsa · ikiwiki · debian · bookworm; dsa · ikiwiki · debian · 12

[Debian 13 (Trixie)]

  • [ikiwiki]Fixed
    Details (2)
    • 3.20250501-1 · all · trixie

      Fixed · Fixed: 3.20141016.2

      dsa · ikiwiki · debian · 13

    • 3.20250501-1 · all · trixie

      Fixed · Fixed: 3.20141016.2

      dsa · ikiwiki · debian · 13

Observed:

References