CVE catalog

CVE-2015-4054

pgbouncer: CVE-2015-4054

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
4.13% · Oct 25, 2026

PgBouncer before 1.5.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) by sending a password packet before a startup packet.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpgbouncersid1.26.1-1fixed
Debianpgbouncerforky1.26.1-1fixed
Debianpgbouncertrixie1.24.1-1+deb13u2fixed
Debianpgbouncerbookworm1.18.0-1+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpgbouncersourcesid1.5.5-1not yet assignedNot reportedNot reported
Debianpgbouncersourceforky1.5.5-1not yet assignedNot reportedNot reported
Debianpgbouncersourcetrixie1.5.5-1not yet assignedNot reportedNot reported
Debianpgbouncersourcebookworm1.5.5-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [pgbouncer]Fixed
    Details (2)
    • 1.18.0-1+deb12u1 · amd64 · bookworm

      Fixed · Fixed: 1.5.5-1

      dsa · pgbouncer · debian · bookworm; dsa · pgbouncer · debian · 12

    • 1.18.0-1+deb12u1 · arm64 · bookworm

      Fixed · Fixed: 1.5.5-1

      dsa · pgbouncer · debian · bookworm; dsa · pgbouncer · debian · 12

[Debian 13 (Trixie)]

  • [pgbouncer]Fixed
    Details (2)
    • 1.24.1-1+deb13u2 · amd64 · trixie

      Fixed · Fixed: 1.5.5-1

      dsa · pgbouncer · debian · 13

    • 1.24.1-1+deb13u2 · arm64 · trixie

      Fixed · Fixed: 1.5.5-1

      dsa · pgbouncer · debian · 13

Observed:

References