CVE catalog

CVE-2015-6584

datatables.js: CVE-2015-6584

[CVE catalog]

Severity
Critical · CVSS 9.8CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
2.68% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiandatatables.jssid1.11.5+dfsg-2fixed
Debiandatatables.jsforky1.11.5+dfsg-2fixed
Debiandatatables.jstrixie1.11.5+dfsg-2fixed
Debiandatatables.jsbookworm1.11.5+dfsg-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiandatatables.jssourcesid1.10.9+dfsg-1not yet assignedNot reportedNot reported
Debiandatatables.jssourceforky1.10.9+dfsg-1not yet assignedNot reportedNot reported
Debiandatatables.jssourcetrixie1.10.9+dfsg-1not yet assignedNot reportedNot reported
Debiandatatables.jssourcebookworm1.10.9+dfsg-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [datatables.js]

    Details (2)
    • 1.11.5+dfsg-2 · all · bookworm

      Fixed · Fixed: 1.10.9+dfsg-1

      dsa · datatables.js · debian · bookworm; dsa · datatables.js · debian · 12

    • 1.11.5+dfsg-2 · all · bookworm

      Fixed · Fixed: 1.10.9+dfsg-1

      dsa · datatables.js · debian · bookworm; dsa · datatables.js · debian · 12

[Debian 13 (Trixie)]

  • Source package: [datatables.js]

    Details (2)
    • 1.11.5+dfsg-2 · all · trixie

      Fixed · Fixed: 1.10.9+dfsg-1

      dsa · datatables.js · debian · 13

    • 1.11.5+dfsg-2 · all · trixie

      Fixed · Fixed: 1.10.9+dfsg-1

      dsa · datatables.js · debian · 13

Observed:

References