CVE catalog

CVE-2015-6817

pgbouncer: CVE-2015-6817

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.16% · Oct 25, 2026

PgBouncer 1.6.x before 1.6.1, when configured with auth_user, allows remote attackers to gain login access as auth_user via an unknown username.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpgbouncersid1.26.1-1fixed
Debianpgbouncerforky1.26.1-1fixed
Debianpgbouncertrixie1.24.1-1+deb13u2fixed
Debianpgbouncerbookworm1.18.0-1+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpgbouncersourcesid1.6.1-1not yet assignedNot reportedNot reported
Debianpgbouncersourceforky1.6.1-1not yet assignedNot reportedNot reported
Debianpgbouncersourcetrixie1.6.1-1not yet assignedNot reportedNot reported
Debianpgbouncersourcebookworm1.6.1-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [pgbouncer]Fixed
    Details (2)
    • 1.18.0-1+deb12u1 · amd64 · bookworm

      Fixed · Fixed: 1.6.1-1

      dsa · pgbouncer · debian · bookworm; dsa · pgbouncer · debian · 12

    • 1.18.0-1+deb12u1 · arm64 · bookworm

      Fixed · Fixed: 1.6.1-1

      dsa · pgbouncer · debian · bookworm; dsa · pgbouncer · debian · 12

[Debian 13 (Trixie)]

  • [pgbouncer]Fixed
    Details (2)
    • 1.24.1-1+deb13u2 · amd64 · trixie

      Fixed · Fixed: 1.6.1-1

      dsa · pgbouncer · debian · 13

    • 1.24.1-1+deb13u2 · arm64 · trixie

      Fixed · Fixed: 1.6.1-1

      dsa · pgbouncer · debian · 13

Observed:

References