CVE catalog

CVE-2015-8856

node-serve-index: CVE-2015-8856

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
2.48% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-serve-indexsid1.9.1+~1.9.4-2fixed
Debiannode-serve-indexforky1.9.1+~1.9.4-2fixed
Debiannode-serve-indextrixie1.9.1-6fixed
Debiannode-serve-indexbookworm1.9.1-6fixed
Ubuntunode-serve-index16.041.4.0-1vulnerable
Ubuntunode-serve-index18.041.4.0-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-serve-indexsourcesid1.9.1-1unimportantNot reportedNot reported
Debiannode-serve-indexsourceforky1.9.1-1unimportantNot reportedNot reported
Debiannode-serve-indexsourcetrixie1.9.1-1unimportantNot reportedNot reported
Debiannode-serve-indexsourcebookworm1.9.1-1unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.9.1-6 · all · bookworm

      Fixed · Fixed: 1.9.1-1

      dsa · node-serve-index · debian · bookworm; dsa · node-serve-index · debian · 12

    • 1.9.1-6 · all · bookworm

      Fixed · Fixed: 1.9.1-1

      dsa · node-serve-index · debian · bookworm; dsa · node-serve-index · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.9.1-6 · all · trixie

      Fixed · Fixed: 1.9.1-1

      dsa · node-serve-index · debian · 13

    • 1.9.1-6 · all · trixie

      Fixed · Fixed: 1.9.1-1

      dsa · node-serve-index · debian · 13

Observed:

References