CVE catalog

CVE-2015-8857

UBUNTU-CVE-2015-8857

[CVE catalog]

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
3.56% · Oct 25, 2026

The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianuglifyjs132.7.4-1fixed
Ubuntuuglifyjs16.042.4.15-4vulnerable
Ubuntuuglifyjs16.042.4.15-5vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianuglifyjsdeb132.7.4-1Not reportedDEBIAN-CVE-2015-8857Not reported

OpenFactory catalog packages

[Debian 13 (Trixie)]

  • Source package: [uglifyjs]

    Details (2)
    • 2.8.29-8+deb13u1 · all · trixie

      Fixed · Fixed: 2.7.4-1

      pypi · uglifyjs · debian · 13

    • 2.8.29-8+deb13u1 · all · trixie

      Fixed · Fixed: 2.7.4-1

      pypi · uglifyjs · debian · 13

  • Source package: [uglifyjs]

    Details (2)
    • 2.8.29-8+deb13u1 · all · trixie

      Fixed · Fixed: 2.7.4-1

      pypi · uglifyjs · debian · 13

    • 2.8.29-8+deb13u1 · all · trixie

      Fixed · Fixed: 2.7.4-1

      pypi · uglifyjs · debian · 13

  • [uglifyjs]Fixed

    Source package: [uglify-js]

    Details (2)
    • 3.17.4-2 · all · trixie

      Fixed · Fixed: 2.7.4-1

      pypi · uglifyjs · debian · 13

    • 3.17.4-2 · all · trixie

      Fixed · Fixed: 2.7.4-1

      pypi · uglifyjs · debian · 13

Observed:

References