CVE catalog

CVE-2015-9284

ruby-omniauth: CVE-2015-9284

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.52% · Oct 25, 2026

The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-omniauthsid2.1.4-1fixed
Debianruby-omniauthforky2.1.4-1fixed
Debianruby-omniauthtrixie2.1.1-4fixed
Debianruby-omniauthbookworm2.1.1-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-omniauthsourcesid2.0.4-2not yet assignedNot reported[973384]
Debianruby-omniauthsourceforky2.0.4-2not yet assignedNot reported[973384]
Debianruby-omniauthsourcetrixie2.0.4-2not yet assignedNot reported[973384]
Debianruby-omniauthsourcebookworm2.0.4-2not yet assignedNot reported[973384]

[Debian bug #973384]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 2.1.1-1 · all · bookworm

      Fixed · Fixed: 2.0.4-2

      dsa · ruby-omniauth · debian · bookworm; dsa · ruby-omniauth · debian · 12

    • 2.1.1-1 · all · bookworm

      Fixed · Fixed: 2.0.4-2

      dsa · ruby-omniauth · debian · bookworm; dsa · ruby-omniauth · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 2.1.1-4 · all · trixie

      Fixed · Fixed: 2.0.4-2

      dsa · ruby-omniauth · debian · 13

    • 2.1.1-4 · all · trixie

      Fixed · Fixed: 2.0.4-2

      dsa · ruby-omniauth · debian · 13

Observed:

References