CVE catalog

CVE-2016-6175

php-gettext: CVE-2016-6175

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
19.66% · Oct 25, 2026

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphp-gettextsid1.0.12-8fixed
Debianphp-gettextforky1.0.12-8fixed
Debianphp-gettextbookworm1.0.12-5fixed
Ubuntuphp-gettextpro1.0.11-1vulnerable
Ubuntuphp-gettextpro1.0.11-2vulnerable
Ubuntuphp-gettextpro1.0.11-2build1vulnerable
Ubuntuphp-gettextpro1.0.11-2ubuntu0.1~esm1vulnerable
Ubuntuphp-gettext18.041.0.12-0.1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphp-gettextsourcesid1.0.12-1not yet assignedNot reported[851771]
Debianphp-gettextsourceforky1.0.12-1not yet assignedNot reported[851771]
Debianphp-gettextsourcebookworm1.0.12-1not yet assignedNot reported[851771]

[Debian bug #851771]

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

[Debian 12 (Bookworm)]

  • Source package: [php-gettext]

    Details (2)
    • 1.0.12-5 · all · bookworm

      Fixed · Fixed: 1.0.12-1

      dsa · php-gettext · debian · bookworm; dsa · php-gettext · debian · 12

    • 1.0.12-5 · all · bookworm

      Fixed · Fixed: 1.0.12-1

      dsa · php-gettext · debian · bookworm; dsa · php-gettext · debian · 12

Observed:

References