CVE catalog

CVE-2016-6606

phpmyadmin: CVE-2016-6606

[CVE catalog]

Severity
High · CVSS 8.1CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.39% · Oct 27, 2026

An issue was discovered in cookie encryption in phpMyAdmin. The decryption of the username/password is vulnerable to a padding oracle attack. This can allow an attacker who has access to a user's browser cookie file to decrypt the username and password. Furthermore, the same initialization vector (IV) is used to hash the username and password stored in the phpMyAdmin cookie. If a user has the same password as their username, an attacker who examines the browser cookie can see that they are the same - but the attacker can not directly decode these values from the cookie as it is still hashed. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphpmyadminsid4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadminforky4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadmintrixie4:5.2.2-really+dfsg-1+deb13u1fixed
Debianphpmyadminbookworm4:5.2.1+dfsg-1+deb12u1fixed
Alpinephpmyadmin3.24.4.15.8-r0fixed
Ubuntuphpmyadmin14.044:4.0.6-1vulnerable
Ubuntuphpmyadmin14.044:4.0.8-1vulnerable
Ubuntuphpmyadmin14.044:4.0.9-1vulnerable
Ubuntuphpmyadmin14.044:4.0.10-1vulnerable
Ubuntuphpmyadmin14.044:4.0.10-1ubuntu0.1fixed
Ubuntuphpmyadmin16.044:4.4.13.1-1vulnerable
Ubuntuphpmyadmin16.044:4.5.0.2-2vulnerable
Ubuntuphpmyadmin16.044:4.5.1-1vulnerable
Ubuntuphpmyadmin16.044:4.5.1-2vulnerable
Ubuntuphpmyadmin16.044:4.5.1-3vulnerable
Ubuntuphpmyadmin16.044:4.5.2-1vulnerable
Ubuntuphpmyadmin16.044:4.5.2-2vulnerable
Ubuntuphpmyadmin16.044:4.5.3.1-1vulnerable
Ubuntuphpmyadmin16.044:4.5.4-1vulnerable
Ubuntuphpmyadmin16.044:4.5.4.1-2vulnerable
Ubuntuphpmyadmin16.044:4.5.4.1-2ubuntu1vulnerable
Ubuntuphpmyadmin16.044:4.5.4.1-2ubuntu2vulnerable
Ubuntuphpmyadmin16.044:4.5.4.1-2ubuntu2.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphpmyadminsourcesid4:4.6.4+dfsg1-1not yet assignedNot reportedNot reported
Debianphpmyadminsourceforky4:4.6.4+dfsg1-1not yet assignedNot reportedNot reported
Debianphpmyadminsourcetrixie4:4.6.4+dfsg1-1not yet assignedNot reportedNot reported
Debianphpmyadminsourcebookworm4:4.6.4+dfsg1-1not yet assignedNot reportedNot reported
Alpinephpmyadminapk3.24.4.15.8-r0Not reportedALPINE-CVE-2016-6606Not reported
Ubuntuphpmyadmindeb14.044:4.0.10-1ubuntu0.1Not reportedUBUNTU-CVE-2016-6606Not reported
Ubuntuphpmyadmindeb16.044:4.5.4.1-2ubuntu2.1Not reportedUBUNTU-CVE-2016-6606Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [phpmyadmin]Fixed
    Details (2)
    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:4.6.4+dfsg1-1

      dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12

    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:4.6.4+dfsg1-1

      dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12

[Debian 13 (Trixie)]

  • [phpmyadmin]Fixed
    Details (2)
    • 4:5.2.2-really+dfsg-1+deb13u1 · all · trixie

      Fixed · Fixed: 4:4.6.4+dfsg1-1

      dsa · phpmyadmin · debian · 13

    • 4:5.2.2-really+dfsg-1+deb13u1 · all · trixie

      Fixed · Fixed: 4:4.6.4+dfsg1-1

      dsa · phpmyadmin · debian · 13

Observed:

References