CVE catalog

CVE-2016-9587

ansible: CVE-2016-9587

[CVE catalog]

Severity
High · CVSS 8.1CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
17.14% · Oct 25, 2026

Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianansiblesid14.4.0+dfsg-1fixed
Debianansibleforky14.0.0+dfsg-1fixed
Debianansibletrixie12.0.0+dfsg-0+deb13u1fixed
Debianansiblebookworm7.7.0+dfsg-3+deb12u1fixed
Alpineansible3.42.1.4.0-r0fixed
Alpineansible3.52.2.1.0-r0fixed
Suseansibleopenstack cloud 72.2.3.0-5.1fixed
Susemonasca-installeropenstack cloud 720170912_10.45-5.1fixed
Ubuntuansible16.041.9.2+dfsg-2vulnerable
Ubuntuansible16.041.9.4-1vulnerable
Ubuntuansible16.042.0.0.2-2vulnerable
Ubuntuansible16.042.0.0.2-2ubuntu1vulnerable
Ubuntuansible16.042.0.0.2-2ubuntu1.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianansiblesourcesid2.2.0.0-3not yet assignedNot reported[850846]
Debianansiblesourceforky2.2.0.0-3not yet assignedNot reported[850846]
Debianansiblesourcetrixie2.2.0.0-3not yet assignedNot reported[850846]
Debianansiblesourcebookworm2.2.0.0-3not yet assignedNot reported[850846]
Alpineansibleapk3.42.1.4.0-r0Not reportedALPINE-CVE-2016-9587Not reported
Alpineansibleapk3.52.2.1.0-r0Not reportedALPINE-CVE-2016-9587Not reported
Suseansiblerpmopenstack cloud 72.2.3.0-5.1Not reportedSUSE-SU-2017:3029-1Not reported
Susemonasca-installerrpmopenstack cloud 720170912_10.45-5.1Not reportedSUSE-SU-2017:3029-1Not reported
Ubuntuansibledeb16.042.0.0.2-2ubuntu1.1Not reportedUBUNTU-CVE-2016-9587Not reported

[Debian bug #850846]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ansible]Fixed
    Details (2)
    • 7.7.0+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 2.2.0.0-3

      dsa · ansible · debian · bookworm; dsa · ansible · debian · 12

    • 7.7.0+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 2.2.0.0-3

      dsa · ansible · debian · bookworm; dsa · ansible · debian · 12

[Debian 13 (Trixie)]

  • [ansible]Fixed
    Details (2)
    • 12.0.0+dfsg-0+deb13u1 · all · trixie

      Fixed · Fixed: 2.2.0.0-3

      dsa · ansible · debian · 13

    • 12.0.0+dfsg-0+deb13u1 · all · trixie

      Fixed · Fixed: 2.2.0.0-3

      dsa · ansible · debian · 13

Observed:

References