CVE catalog

CVE-2017-1000228

node-ejs: CVE-2017-1000228

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
6.33% · Oct 25, 2026

nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-ejssid3.1.10+~3.1.5-2fixed
Debiannode-ejsforky3.1.10+~3.1.5-2fixed
Debiannode-ejstrixie3.1.10+~3.1.5-2fixed
Debiannode-ejsbookworm3.1.8+~3.1.1-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-ejssourcesid2.5.7-1not yet assignedNot reportedNot reported
Debiannode-ejssourceforky2.5.7-1not yet assignedNot reportedNot reported
Debiannode-ejssourcetrixie2.5.7-1not yet assignedNot reportedNot reported
Debiannode-ejssourcebookworm2.5.7-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [node-ejs]Fixed
    Details (2)
    • 3.1.8+~3.1.1-2 · all · bookworm

      Fixed · Fixed: 2.5.7-1

      dsa · node-ejs · debian · bookworm; dsa · node-ejs · debian · 12

    • 3.1.8+~3.1.1-2 · all · bookworm

      Fixed · Fixed: 2.5.7-1

      dsa · node-ejs · debian · bookworm; dsa · node-ejs · debian · 12

[Debian 13 (Trixie)]

  • [node-ejs]Fixed
    Details (2)
    • 3.1.10+~3.1.5-2 · all · trixie

      Fixed · Fixed: 2.5.7-1

      dsa · node-ejs · debian · 13

    • 3.1.10+~3.1.5-2 · all · trixie

      Fixed · Fixed: 2.5.7-1

      dsa · node-ejs · debian · 13

Observed:

References