
CVE catalog
CVE-2017-1000376
libffi: CVE-2017-1000376
- Severity
- High · CVSS 7.4
CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.50% · Oct 25, 2026
libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libffi | sid | 3.8.0-2 | fixed |
| Debian | libffi | forky | 3.8.0-2 | fixed |
| Debian | libffi | trixie | 3.4.8-2 | fixed |
| Debian | libffi | bookworm | 3.4.4-1 | fixed |
| Ubuntu | libffi | 14.04 | 3.0.13-4 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-5 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-6 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-9ubuntu1 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-10 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-10build1 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-11 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-12 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1-2 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1+r3.0.13-12 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1+r3.0.13-12ubuntu0.1 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1+r3.0.13-12ubuntu0.2 | fixed |
| Ubuntu | libffi | 14.04 | 3.0.13-4 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-5 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-6 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-9ubuntu1 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-10 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-10build1 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-11 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.0.13-12 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1-2 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1+r3.0.13-12 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1+r3.0.13-12ubuntu0.1 | vulnerable |
| Ubuntu | libffi | 14.04 | 3.1~rc1+r3.0.13-12ubuntu0.2 | fixed |
| Suse | gcc43 | linux enterprise software development kit 11 sp4 | 4.3.4_20091019-37.3.1 | fixed |
| Suse | gcc43 | linux enterprise point of sale 11 sp3 | 4.3.4_20091019-37.3.1 | fixed |
| Suse | gcc43 | linux enterprise server 11 sp3-ltss | 4.3.4_20091019-37.3.1 | fixed |
| Suse | gcc43 | linux enterprise server 11 sp3-teradata | 4.3.4_20091019-37.3.1 | fixed |
| Suse | gcc43 | linux enterprise server 11 sp4 | 4.3.4_20091019-37.3.1 | fixed |
| Suse | gcc43 | linux enterprise server for sap applications 11 sp4 | 4.3.4_20091019-37.3.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libffi | source | sid | 3.2.1-4 | not yet assigned | Not reported | Not reported |
| Debian | libffi | source | forky | 3.2.1-4 | not yet assigned | Not reported | Not reported |
| Debian | libffi | source | trixie | 3.2.1-4 | not yet assigned | Not reported | Not reported |
| Debian | libffi | source | bookworm | 3.2.1-4 | not yet assigned | Not reported | Not reported |
| Ubuntu | libffi | deb | 14.04 | 3.1~rc1+r3.0.13-12ubuntu0.2 | Not reported | UBUNTU-CVE-2017-1000376 | Not reported |
| Ubuntu | libffi | deb | 14.04 | 3.1~rc1+r3.0.13-12ubuntu0.2 | Not reported | USN-3454-1 | Not reported |
| Suse | gcc43 | rpm | linux enterprise software development kit 11 sp4 | 4.3.4_20091019-37.3.1 | Not reported | SUSE-SU-2018:0300-1 | Not reported |
| Suse | gcc43 | rpm | linux enterprise point of sale 11 sp3 | 4.3.4_20091019-37.3.1 | Not reported | SUSE-SU-2018:0300-1 | Not reported |
| Suse | gcc43 | rpm | linux enterprise server 11 sp3-ltss | 4.3.4_20091019-37.3.1 | Not reported | SUSE-SU-2018:0300-1 | Not reported |
| Suse | gcc43 | rpm | linux enterprise server 11 sp3-teradata | 4.3.4_20091019-37.3.1 | Not reported | SUSE-SU-2018:0300-1 | Not reported |
| Suse | gcc43 | rpm | linux enterprise server 11 sp4 | 4.3.4_20091019-37.3.1 | Not reported | SUSE-SU-2018:0300-1 | Not reported |
| Suse | gcc43 | rpm | linux enterprise server for sap applications 11 sp4 | 4.3.4_20091019-37.3.1 | Not reported | SUSE-SU-2018:0300-1 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libffi8]Fixed
Source package: [libffi]
Details (2)
3.4.4-1· amd64 · bookwormFixed · Fixed:
3.2.1-4dsa · libffi · debian · bookworm; dsa · libffi · debian · 12
3.4.4-1· arm64 · bookwormFixed · Fixed:
3.2.1-4dsa · libffi · debian · bookworm; dsa · libffi · debian · 12
- [libffi-dev]Fixed
Source package: [libffi]
Details (2)
3.4.4-1· amd64 · bookwormFixed · Fixed:
3.2.1-4dsa · libffi · debian · bookworm; dsa · libffi · debian · 12
3.4.4-1· arm64 · bookwormFixed · Fixed:
3.2.1-4dsa · libffi · debian · bookworm; dsa · libffi · debian · 12
[Debian 13 (Trixie)]
- [libffi8]Fixed
Source package: [libffi]
Details (2)
3.4.8-2· amd64 · trixieFixed · Fixed:
3.2.1-4dsa · libffi · debian · 13
3.4.8-2· arm64 · trixieFixed · Fixed:
3.2.1-4dsa · libffi · debian · 13
- [libffi-dev]Fixed
Source package: [libffi]
Details (2)
3.4.8-2· amd64 · trixieFixed · Fixed:
3.2.1-4dsa · libffi · debian · 13
3.4.8-2· arm64 · trixieFixed · Fixed:
3.2.1-4dsa · libffi · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2018_0300-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000376]
- [https://osv.dev/vulnerability/DLA-997-1]
- [https://osv.dev/vulnerability/DSA-3889-1]
- [https://osv.dev/vulnerability/SUSE-SU-2018:0300-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2017-1000376]
- [https://osv.dev/vulnerability/USN-3454-1]
- [https://security-tracker.debian.org/tracker/CVE-2017-1000376]
- [https://security.access.redhat.com/data/csaf/v2/vex/2017/cve-2017-1000376.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]