CVE catalog

CVE-2017-11428

Ruby SAML vulnerabilities

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.46% · Oct 25, 2026

OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-samlbookworm1.13.0-1+deb12u1fixed
Debianruby-samlbookworm-security1.13.0-1+deb12u1fixed
Ubunturuby-samlnoble1.15.0-1ubuntu0.24.04.1fixed
Ubunturuby-samlpro0.9.2-1vulnerable
Ubunturuby-samlpro1.0.0-1vulnerable
Ubunturuby-samlpro1.1.2-1ubuntu1vulnerable
Ubunturuby-samlpro1.1.2-1ubuntu1+esm1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-samlsourcebookworm1.7.2-1not yet assignedNot reported[892865]
Ubunturuby-samldebnoble1.15.0-1ubuntu0.24.04.1Not reportedNot reportedNot reported
Ubunturuby-samldebpro1.1.2-1ubuntu1+esm1Not reportedUBUNTU-CVE-2017-11428Not reported

[Debian bug #892865]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ruby-saml]Fixed
    Details (4)
    • 1.13.0-1+deb12u1 · all · bookworm

      Fixed · Fixed: 1.7.2-1

      usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12

    • 1.13.0-1+deb12u1 · all · bookworm

      Fixed · Fixed: 1.7.2-1

      usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12

    • 1.13.0-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.7.2-1

      usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12

    • 1.13.0-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.7.2-1

      usn · ruby-saml · debian · bookworm; usn · ruby-saml · debian · 12

Observed:

References