CVE catalog

CVE-2017-12873

simplesamlphp: CVE-2017-12873

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.66% · Oct 25, 2026

SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive information, gain unauthorized access, or have unspecified other impacts by leveraging incorrect persistent NameID generation when an Identity Provider (IdP) is misconfigured.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiansimplesamlphpsid2.5.3.1-1fixed
Debiansimplesamlphpforky2.5.3.1-1fixed
Debiansimplesamlphpbookworm1.19.7-1+deb12u2fixed
Debiansimplesamlphpbookworm-security1.19.7-1+deb12u1fixed
Ubuntusimplesamlphppro1.13.2-1vulnerable
Ubuntusimplesamlphppro1.14.0-1vulnerable
Ubuntusimplesamlphppro1.14.0-1ubuntu2vulnerable
Ubuntusimplesamlphppro1.14.0-1ubuntu2+esm1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiansimplesamlphpsourcesid1.14.11-1not yet assignedNot reportedNot reported
Debiansimplesamlphpsourceforky1.14.11-1not yet assignedNot reportedNot reported
Debiansimplesamlphpsourcebookworm1.14.11-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (4)
    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.14.11-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.14.11-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.14.11-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.14.11-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

Observed:

References