CVE catalog

CVE-2017-12961

pspp: CVE-2017-12961

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.26% · Oct 25, 2026

There is an assertion abort in the function parse_attributes() in data/sys-file-reader.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpsppsid2.1.2-1fixed
Debianpsppforky2.1.2-1fixed
Debianpspptrixie2.0.1-1fixed
Debianpsppbookworm1.6.2-2fixed
Ubuntupspp16.040.8.5-4vulnerable
Ubuntupspp16.040.8.5-4build1vulnerable
Ubuntupspp16.040.8.5-5vulnerable
Ubuntupspp16.040.8.5-5build1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpsppsourcesid1.0.1-1unimportantNot reportedNot reported
Debianpsppsourceforky1.0.1-1unimportantNot reportedNot reported
Debianpsppsourcetrixie1.0.1-1unimportantNot reportedNot reported
Debianpsppsourcebookworm1.0.1-1unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [pspp]Fixed
    Details (2)
    • 1.6.2-2 · amd64 · bookworm

      Fixed · Fixed: 1.0.1-1

      dsa · pspp · debian · bookworm

    • 1.6.2-2 · arm64 · bookworm

      Fixed · Fixed: 1.0.1-1

      dsa · pspp · debian · bookworm

Observed:

References