CVE catalog

CVE-2017-14313

wordpress-shibboleth: CVE-2017-14313

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.46% · Oct 25, 2026

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianwordpress-shibbolethtrixie1.8-1.1fixed
Debianwordpress-shibbolethbookworm1.8-1.1fixed
Ubuntuwordpress-shibboleth14.041.4-2vulnerable
Ubuntuwordpress-shibboleth14.041.4-2+deb8u1build0.14.04.2fixed
Ubuntuwordpress-shibboleth16.041.4-2vulnerable
Ubuntuwordpress-shibboleth16.041.4-2+deb8u1build0.16.04.2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianwordpress-shibbolethsourcetrixie1.8-1not yet assignedNot reported[874416]
Debianwordpress-shibbolethsourcebookworm1.8-1not yet assignedNot reported[874416]
Ubuntuwordpress-shibbolethdeb14.041.4-2+deb8u1build0.14.04.2Not reportedUBUNTU-CVE-2017-14313Not reported
Ubuntuwordpress-shibbolethdeb16.041.4-2+deb8u1build0.16.04.2Not reportedUBUNTU-CVE-2017-14313Not reported

[Debian bug #874416]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.8-1.1 · all · bookworm

      Fixed · Fixed: 1.8-1

      dsa · wordpress-shibboleth · debian · bookworm; dsa · wordpress-shibboleth · debian · 12

    • 1.8-1.1 · all · bookworm

      Fixed · Fixed: 1.8-1

      dsa · wordpress-shibboleth · debian · bookworm; dsa · wordpress-shibboleth · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.8-1.1 · all · trixie

      Fixed · Fixed: 1.8-1

      dsa · wordpress-shibboleth · debian · 13

    • 1.8-1.1 · all · trixie

      Fixed · Fixed: 1.8-1

      dsa · wordpress-shibboleth · debian · 13

Observed:

References