
CVE catalog
CVE-2017-15099
UBUNTU-CVE-2017-15099
- Severity
- High · CVSS 7.8
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 6.32% · Oct 25, 2026
INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, and 9.5.x before 9.5.10 disclose table contents that the invoker lacks privilege to read. These exploits affect only tables where the attacker lacks full read access but has both INSERT and UPDATE privileges. Exploits bypass row level security policies and lack of SELECT privilege.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Alpine | postgresql | 3.10 | 10.1-r0 | fixed |
| Alpine | postgresql | 3.11 | 10.1-r0 | fixed |
| Alpine | postgresql | 3.12 | 10.1-r0 | fixed |
| Alpine | postgresql | 3.13 | 10.1-r0 | fixed |
| Alpine | postgresql | 3.14 | 10.1-r0 | fixed |
| Alpine | postgresql | 3.4 | 9.5.10-r0 | fixed |
| Alpine | postgresql | 3.5 | 9.6.6-r0 | fixed |
| Alpine | postgresql | 3.6 | 9.6.6-r0 | fixed |
| Alpine | postgresql | 3.7 | 10.1-r0 | fixed |
| Alpine | postgresql | 3.8 | 10.1-r0 | fixed |
| Alpine | postgresql | 3.9 | 10.1-r0 | fixed |
| Alpine | postgresql14 | 3.15 | 10.1-r0 | fixed |
| Alpine | postgresql14 | 3.16 | 10.1-r0 | fixed |
| Alpine | postgresql14 | 3.17 | 10.1-r0 | fixed |
| Alpine | postgresql14 | 3.18 | 10.1-r0 | fixed |
| Alpine | postgresql15 | 3.17 | 10.1-r0 | fixed |
| Alpine | postgresql15 | 3.18 | 10.1-r0 | fixed |
| Alpine | postgresql15 | 3.19 | 10.1-r0 | fixed |
| Alpine | postgresql15 | 3.20 | 10.1-r0 | fixed |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.0-1 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.0-2 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.0-3 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.1-1 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.2-1 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.3-0ubuntu0.16.04 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.4-0ubuntu0.16.04 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.5-0ubuntu0.16.04 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.6-0ubuntu0.16.04 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.7-0ubuntu0.16.04 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.8-0ubuntu0.16.04.1 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.9-0ubuntu0.16.04 | vulnerable |
| Ubuntu | postgresql-9.5 | 16.04 | 9.5.10-0ubuntu0.16.04 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Alpine | postgresql | apk | 3.10 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.11 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.12 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.13 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.14 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.4 | 9.5.10-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.5 | 9.6.6-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.6 | 9.6.6-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.7 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.8 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql | apk | 3.9 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql14 | apk | 3.15 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql14 | apk | 3.16 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql14 | apk | 3.17 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql14 | apk | 3.18 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql15 | apk | 3.17 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql15 | apk | 3.18 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql15 | apk | 3.19 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Alpine | postgresql15 | apk | 3.20 | 10.1-r0 | Not reported | ALPINE-CVE-2017-15099 | Not reported |
| Ubuntu | postgresql-9.5 | deb | 16.04 | 9.5.10-0ubuntu0.16.04 | Not reported | UBUNTU-CVE-2017-15099 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2017_3391-1.json]
- [https://osv.dev/vulnerability/ALPINE-CVE-2017-15099]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2017-15099]
- [https://security.access.redhat.com/data/csaf/v2/vex/2017/cve-2017-15099.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]