
CVE catalog
CVE-2017-15535
UBUNTU-CVE-2017-15535
- Severity
- Critical · CVSS 9.1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.57% · Oct 25, 2026
This update for mongodb 3.4.10 fixes the following issues: Security issues fixed: - CVE-2017-15535: MongoDB 3.4.x before 3.4.10, and 3.5.x-development, has a disabled-by-default configuration setting, networkMessageCompressors (aka wire protocol compression), which exposes a vulnerability when enabled that could be exploited by a malicious attacker to deny service or modify memory. (boo#1065956) Bug fixes: - See release-notes for 3.4.4 - 3.4.10 changes. * https://docs.mongodb.com/manual/release-notes/3.4-changelog/
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Suse | mongodb | package hub 12 sp2 | 3.4.10-5.1 | fixed |
| Suse | mongodb | package hub 12 sp2 | 3.4.10-5.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Suse | mongodb | rpm | package hub 12 sp2 | 3.4.10-5.1 | Not reported | OPENSUSE-SU-2017:3022-1 | Not reported |
| Suse | mongodb | rpm | package hub 12 sp2 | 3.4.10-5.1 | Not reported | OPENSUSE-SU-2017:3018-1 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2017_3018-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2017-15535]
- [https://osv.dev/vulnerability/openSUSE-SU-2017:3018-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2017:3022-1]
- [https://security.access.redhat.com/data/csaf/v2/vex/2017/cve-2017-15535.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]