CVE catalog

CVE-2017-17512

sensible-utils affected and fixed versions

[CVE catalog]

sensible-browser in sensible-utils before 0.0.11 does not validate strings before launching the program specified by the BROWSER environment variable, which allows remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by a --proxy-pac-file argument.

Severity
High · CVSS 8.8CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C
Published
Source
[NVD] · [CVE record]
EPSS
2.35% · Oct 27, 2026

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Debiantrixiesensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debiantrixiesensible-utils0.0.25Fixed[CVE-2017-17512]
Debiansidsensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debiansidsensible-utils0.0.26Fixed[CVE-2017-17512]
Debianforkysensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debianforkysensible-utils0.0.26Fixed[CVE-2017-17512]
Debianbookwormsensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debianbookwormsensible-utils0.0.17+nmu1Fixed[CVE-2017-17512]

Showing 8 fix observations. All 13 observations, including unknown and conflicting reports, are available below.

Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
UnknownRelease not reportedsensible-utils0.0.11UnknownSource applicability is not establishedProvider not reported
Debianbookwormsensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debianbookwormsensible-utils0.0.17+nmu1Fixed[CVE-2017-17512]
Debianforkysensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debianforkysensible-utils0.0.26Fixed[CVE-2017-17512]
Debiansidsensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debiansidsensible-utils0.0.26Fixed[CVE-2017-17512]
Debiantrixiesensible-utils0.0.11FixedDistribution-reported fixed boundary[CVE-2017-17512]
Debiantrixiesensible-utils0.0.25Fixed[CVE-2017-17512]
Ubuntu14.04sensible-utils0.0.9UnknownSource applicability is not established[USN-3584-1][UBUNTU-CVE-2017-17512]
Ubuntu14.04sensible-utils0.0.9ubuntu0.14.04.1UnknownSource applicability is not established[USN-3584-1][UBUNTU-CVE-2017-17512]
Ubuntu16.04sensible-utils0.0.9UnknownSource applicability is not established[USN-3584-1][UBUNTU-CVE-2017-17512]
Ubuntu16.04sensible-utils0.0.9ubuntu0.16.04.1UnknownSource applicability is not established[USN-3584-1][UBUNTU-CVE-2017-17512]
Original provider fields
{
  "package_releases": [
    {
      "name": "sensible-utils",
      "status": "fixed",
      "release": "sid",
      "version": "0.0.26"
    },
    {
      "name": "sensible-utils",
      "status": "fixed",
      "release": "forky",
      "version": "0.0.26"
    },
    {
      "name": "sensible-utils",
      "status": "fixed",
      "release": "trixie",
      "version": "0.0.25"
    },
    {
      "name": "sensible-utils",
      "status": "fixed",
      "release": "bookworm",
      "version": "0.0.17+nmu1"
    }
  ],
  "fixed_versions": [
    {
      "bug": 881767,
      "name": "sensible-utils",
      "type": "source",
      "origin": null,
      "release": "sid",
      "urgency": "not yet assigned",
      "fixed_version": "0.0.11"
    },
    {
      "bug": 881767,
      "name": "sensible-utils",
      "type": "source",
      "origin": null,
      "release": "forky",
      "urgency": "not yet assigned",
      "fixed_version": "0.0.11"
    },
    {
      "bug": 881767,
      "name": "sensible-utils",
      "type": "source",
      "origin": null,
      "release": "trixie",
      "urgency": "not yet assigned",
      "fixed_version": "0.0.11"
    },
    {
      "bug": 881767,
      "name": "sensible-utils",
      "type": "source",
      "origin": null,
      "release": "bookworm",
      "urgency": "not yet assigned",
      "fixed_version": "0.0.11"
    }
  ],
  "distribution_packages": [
    {
      "name": "sensible-utils",
      "fixed_version": "0.0.11",
      "applicability_unknown": true
    },
    {
      "name": "sensible-utils",
      "ranges": [
        {
          "fixed": "0.0.11",
          "introduced": "",
          "last_affected": "",
          "start_excluding": ""
        }
      ],
      "ecosystem": "cpe",
      "provider_url": "https://nvd.nist.gov/vuln/detail/CVE-2017-17512",
      "fixed_version": "0.0.11",
      "provider_source": "nvd",
      "provider_record_id": "NVD-CVE-2017-17512",
      "provider_updated_at": "2026-10-14T07:16:39.930"
    },
    {
      "name": "sensible-utils",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "0.0.9ubuntu0.14.04.1"
            }
          ]
        }
      ],
      "release": "14.04",
      "versions": [
        "0.0.9"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/USN-3584-1",
      "fixed_version": "0.0.9ubuntu0.14.04.1",
      "provider_source": "pypi",
      "provider_record_id": "USN-3584-1",
      "provider_updated_at": "2026-02-10T04:41:17Z",
      "applicability_unknown": true
    },
    {
      "name": "sensible-utils",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "0.0.9ubuntu0.16.04.1"
            }
          ]
        }
      ],
      "release": "16.04",
      "versions": [
        "0.0.9"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/USN-3584-1",
      "fixed_version": "0.0.9ubuntu0.16.04.1",
      "provider_source": "pypi",
      "provider_record_id": "USN-3584-1",
      "provider_updated_at": "2026-02-10T04:41:17Z",
      "applicability_unknown": true
    },
    {
      "name": "sensible-utils",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "0.0.9ubuntu0.14.04.1"
            }
          ]
        }
      ],
      "release": "14.04",
      "versions": [
        "0.0.9"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2017-17512",
      "fixed_version": "0.0.9ubuntu0.14.04.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2017-17512",
      "provider_updated_at": "2026-02-04T02:56:57.436139Z",
      "applicability_unknown": true
    },
    {
      "name": "sensible-utils",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "0.0.9ubuntu0.16.04.1"
            }
          ]
        }
      ],
      "release": "16.04",
      "versions": [
        "0.0.9"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2017-17512",
      "fixed_version": "0.0.9ubuntu0.16.04.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2017-17512",
      "provider_updated_at": "2026-02-04T02:56:57.436139Z",
      "applicability_unknown": true
    }
  ]
}

[Debian bug #881767]

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

[Debian 12 (Bookworm)]

  • Details (2)
    • 0.0.17+nmu1 · all · bookworm

      Fixed · Fixed: 0.0.11

      dsa · sensible-utils · debian · bookworm

    • 0.0.17+nmu1 · all · bookworm

      Fixed · Fixed: 0.0.11

      dsa · sensible-utils · debian · bookworm

Observed:

References