CVE catalog

CVE-2017-18077

node-brace-expansion: CVE-2017-18077

[CVE catalog]

Severity
Medium · CVSS 5.3CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Published
Source
[NVD] · [CVE record]
EPSS
2.58% · Oct 25, 2026

index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-brace-expansionsid2.1.7+~1.1.2-1fixed
Debiannode-brace-expansionforky2.1.7+~1.1.2-1fixed
Debiannode-brace-expansiontrixie2.0.1+~1.1.0-2fixed
Debiannode-brace-expansionbookworm2.0.1-2fixed
Npmbrace-expansionNot reported1.1.7fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-brace-expansionsourcesid1.1.8-1unimportantNot reported[862712]
Debiannode-brace-expansionsourceforky1.1.8-1unimportantNot reported[862712]
Debiannode-brace-expansionsourcetrixie1.1.8-1unimportantNot reported[862712]
Debiannode-brace-expansionsourcebookworm1.1.8-1unimportantNot reported[862712]
Npmbrace-expansionnpmNot reported1.1.7Not reportedNot reportedNot reported

[Debian bug #862712]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 2.0.1-2 · all · bookworm

      Fixed · Fixed: 1.1.8-1

      dsa · node-brace-expansion · debian · bookworm; dsa · node-brace-expansion · debian · 12

    • 2.0.1-2 · all · bookworm

      Fixed · Fixed: 1.1.8-1

      dsa · node-brace-expansion · debian · bookworm; dsa · node-brace-expansion · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 2.0.1+~1.1.0-2 · all · trixie

      Fixed · Fixed: 1.1.8-1

      dsa · node-brace-expansion · debian · 13

    • 2.0.1+~1.1.0-2 · all · trixie

      Fixed · Fixed: 1.1.8-1

      dsa · node-brace-expansion · debian · 13

Observed:

References