CVE catalog

CVE-2017-18121

simplesamlphp: CVE-2017-18121

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.19% · Oct 25, 2026

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiansimplesamlphpsid2.5.3.1-1fixed
Debiansimplesamlphpforky2.5.3.1-1fixed
Debiansimplesamlphpbookworm1.19.7-1+deb12u2fixed
Debiansimplesamlphpbookworm-security1.19.7-1+deb12u1fixed
Ubuntusimplesamlphppro1.13.2-1vulnerable
Ubuntusimplesamlphppro1.14.0-1vulnerable
Ubuntusimplesamlphppro1.14.0-1ubuntu2vulnerable
Ubuntusimplesamlphppro1.14.0-1ubuntu2+esm1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiansimplesamlphpsourcesid1.15.0-1not yet assignedNot reported[889286]
Debiansimplesamlphpsourceforky1.15.0-1not yet assignedNot reported[889286]
Debiansimplesamlphpsourcebookworm1.15.0-1not yet assignedNot reported[889286]

[Debian bug #889286]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (4)
    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.15.0-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.15.0-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.15.0-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.15.0-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

Observed:

References