CVE catalog

CVE-2017-18264

phpmyadmin: CVE-2017-18264

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.82% · Oct 25, 2026

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphpmyadminsid4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadminforky4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadmintrixie4:5.2.2-really+dfsg-1+deb13u1fixed
Debianphpmyadminbookworm4:5.2.1+dfsg-1+deb12u1fixed
Ubuntuphpmyadminpro4:4.4.13.1-1vulnerable
Ubuntuphpmyadminpro4:4.5.0.2-2vulnerable
Ubuntuphpmyadminpro4:4.5.1-1vulnerable
Ubuntuphpmyadminpro4:4.5.1-2vulnerable
Ubuntuphpmyadminpro4:4.5.1-3vulnerable
Ubuntuphpmyadminpro4:4.5.2-1vulnerable
Ubuntuphpmyadminpro4:4.5.2-2vulnerable
Ubuntuphpmyadminpro4:4.5.3.1-1vulnerable
Ubuntuphpmyadminpro4:4.5.4-1vulnerable
Ubuntuphpmyadminpro4:4.5.4.1-2vulnerable
Ubuntuphpmyadminpro4:4.5.4.1-2ubuntu1vulnerable
Ubuntuphpmyadminpro4:4.5.4.1-2ubuntu2vulnerable
Ubuntuphpmyadminpro4:4.5.4.1-2ubuntu2.1vulnerable
Ubuntuphpmyadminpro4:4.5.4.1-2ubuntu2.1+esm2vulnerable
Ubuntuphpmyadminpro4:4.5.4.1-2ubuntu2.1+esm3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphpmyadminsourcesid4:4.6.6-2not yet assignedNot reportedNot reported
Debianphpmyadminsourceforky4:4.6.6-2not yet assignedNot reportedNot reported
Debianphpmyadminsourcetrixie4:4.6.6-2not yet assignedNot reportedNot reported
Debianphpmyadminsourcebookworm4:4.6.6-2not yet assignedNot reportedNot reported
Ubuntuphpmyadmindebpro4:4.5.4.1-2ubuntu2.1+esm3Not reportedUBUNTU-CVE-2017-18264Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [phpmyadmin]Fixed
    Details (2)
    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:4.6.6-2

      dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12

    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:4.6.6-2

      dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12

[Debian 13 (Trixie)]

  • [phpmyadmin]Fixed
    Details (2)
    • 4:5.2.2-really+dfsg-1+deb13u1 · all · trixie

      Fixed · Fixed: 4:4.6.6-2

      dsa · phpmyadmin · debian · 13

    • 4:5.2.2-really+dfsg-1+deb13u1 · all · trixie

      Fixed · Fixed: 4:4.6.6-2

      dsa · phpmyadmin · debian · 13

Observed:

References