CVE catalog

CVE-2017-5846

gst-plugins-ugly1.0: CVE-2017-5846

[CVE catalog]

Severity
Medium · CVSS 5.5CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
2.03% · Oct 25, 2026

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiangst-plugins-ugly1.0sid1.28.8-1fixed
Debiangst-plugins-ugly1.0forky1.28.8-1fixed
Debiangst-plugins-ugly1.0trixie1.26.3-4+deb13u1fixed
Debiangst-plugins-ugly1.0trixie-security1.26.3-4+deb13u1fixed
Debiangst-plugins-ugly1.0bookworm1.22.0-2+deb12u2fixed
Debiangst-plugins-ugly1.0bookworm-security1.22.0-2+deb12u2fixed
Ubuntugst-plugins-ugly0.1014.040.10.19-2vulnerable
Ubuntugst-plugins-ugly0.1014.040.10.19-2ubuntu1vulnerable
Ubuntugst-plugins-ugly0.1014.040.10.19-2ubuntu2vulnerable
Ubuntugst-plugins-ugly0.1014.040.10.19-2ubuntu3vulnerable
Ubuntugst-plugins-ugly0.1014.040.10.19-2ubuntu5vulnerable
Ubuntugst-plugins-ugly0.1014.040.10.19-2+deb7u1ubuntu0.1fixed
Ubuntugst-plugins-ugly1.0pro1.6.0-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.6.1-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.6.2-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.7.1-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.7.2-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.7.90-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.7.91-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.8.0-1ubuntu1vulnerable
Ubuntugst-plugins-ugly1.0pro1.8.1-1ubuntu0.1vulnerable
Ubuntugst-plugins-ugly1.0pro1.8.2-1ubuntu0.1vulnerable
Ubuntugst-plugins-ugly1.0pro1.8.3-1ubuntu0.1vulnerable
Ubuntugst-plugins-ugly1.0pro1.8.3-1ubuntu0.1+esm1vulnerable
Ubuntugst-plugins-ugly1.0pro1.8.3-1ubuntu0.1+esm2vulnerable
Alpinegst-plugins-ugly3.71.10.4-r0fixed
Alpinegst-plugins-ugly13.41.8.3-r0fixed
Alpinegst-plugins-ugly13.51.8.3-r0fixed
Alpinegst-plugins-ugly13.61.10.4-r0fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiangst-plugins-ugly1.0sourcesid1.10.3-1lowNot reportedNot reported
Debiangst-plugins-ugly1.0sourceforky1.10.3-1lowNot reportedNot reported
Debiangst-plugins-ugly1.0sourcetrixie1.10.3-1lowNot reportedNot reported
Debiangst-plugins-ugly1.0sourcebookworm1.10.3-1lowNot reportedNot reported
Ubuntugst-plugins-ugly0.10deb14.040.10.19-2+deb7u1ubuntu0.1Not reportedUBUNTU-CVE-2017-5846Not reported
Alpinegst-plugins-uglyapk3.71.10.4-r0Not reportedALPINE-CVE-2017-5846Not reported
Alpinegst-plugins-ugly1apk3.41.8.3-r0Not reportedALPINE-CVE-2017-5846Not reported
Alpinegst-plugins-ugly1apk3.51.8.3-r0Not reportedALPINE-CVE-2017-5846Not reported
Alpinegst-plugins-ugly1apk3.61.10.4-r0Not reportedALPINE-CVE-2017-5846Not reported

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

[Debian 12 (Bookworm)]

  • Source package: [gst-plugins-ugly1.0]

    Details (4)
    • 1.22.0-2+deb12u2 · amd64 · bookworm

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · bookworm; dsa · gst-plugins-ugly1.0 · debian · 12

    • 1.22.0-2+deb12u2 · arm64 · bookworm

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · bookworm; dsa · gst-plugins-ugly1.0 · debian · 12

    • 1.22.0-2+deb12u2 · amd64 · bookworm-security

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · bookworm; dsa · gst-plugins-ugly1.0 · debian · 12

    • 1.22.0-2+deb12u2 · arm64 · bookworm-security

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · bookworm; dsa · gst-plugins-ugly1.0 · debian · 12

[Debian 13 (Trixie)]

  • Source package: [gst-plugins-ugly1.0]

    Details (4)
    • 1.26.3-4+deb13u1 · amd64 · trixie

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · 13

    • 1.26.3-4+deb13u1 · arm64 · trixie

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · 13

    • 1.26.3-4+deb13u1 · amd64 · trixie-security

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · 13

    • 1.26.3-4+deb13u1 · arm64 · trixie-security

      Fixed · Fixed: 1.10.3-1

      dsa · gst-plugins-ugly1.0 · debian · 13

Observed:

References