CVE catalog

CVE-2017-9229

libonig: CVE-2017-9229

[CVE catalog]

Severity
Medium · CVSS 6.5CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
Published
Source
[NVD] · [CVE record]
EPSS
5.13% · Oct 25, 2026

An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibonigsid6.9.10-1fixed
Debianlibonigforky6.9.10-1fixed
Debianlibonigtrixie6.9.9-1fixed
Debianlibonigbookworm6.9.8-1fixed
Alpinephp53.45.6.31-r0fixed
Alpinephp53.55.6.31-r0fixed
Ubuntulibonig14.045.9.1-1vulnerable
Ubuntulibonig14.045.9.1-1ubuntu1vulnerable
Ubuntulibonig14.045.9.1-1ubuntu1.1fixed
Ubuntuphp514.045.5.3+dfsg-1ubuntu2vulnerable
Ubuntuphp514.045.5.3+dfsg-1ubuntu3vulnerable
Ubuntuphp514.045.5.6+dfsg-1ubuntu1vulnerable
Ubuntuphp514.045.5.6+dfsg-1ubuntu2vulnerable
Ubuntuphp514.045.5.8+dfsg-2ubuntu1vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu1vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu2vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu3vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.1vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.2vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.3vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.4vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.5vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.6vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.7vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.9vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.11vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.12vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.13vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.14vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.16vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.17vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.19vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.20vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.21vulnerable
Ubuntuphp514.045.5.9+dfsg-1ubuntu4.22fixed
Ubuntulibonig16.045.9.6-1vulnerable
Ubuntulibonig16.045.9.6-1ubuntu0.1fixed
Ubuntuphp7.016.047.0.1-5vulnerable
Ubuntuphp7.016.047.0.1-6vulnerable
Ubuntuphp7.016.047.0.2-1vulnerable
Ubuntuphp7.016.047.0.2-3vulnerable
Ubuntuphp7.016.047.0.2-4vulnerable
Ubuntuphp7.016.047.0.2-5vulnerable
Ubuntuphp7.016.047.0.3-2vulnerable
Ubuntuphp7.016.047.0.3-3vulnerable
Ubuntuphp7.016.047.0.3-9ubuntu1vulnerable
Ubuntuphp7.016.047.0.4-5ubuntu1vulnerable
Ubuntuphp7.016.047.0.4-5ubuntu2vulnerable
Ubuntuphp7.016.047.0.4-7ubuntu1vulnerable
Ubuntuphp7.016.047.0.4-7ubuntu2vulnerable
Ubuntuphp7.016.047.0.4-7ubuntu2.1vulnerable
Ubuntuphp7.016.047.0.8-0ubuntu0.16.04.1vulnerable
Ubuntuphp7.016.047.0.8-0ubuntu0.16.04.2vulnerable
Ubuntuphp7.016.047.0.8-0ubuntu0.16.04.3vulnerable
Ubuntuphp7.016.047.0.13-0ubuntu0.16.04.1vulnerable
Ubuntuphp7.016.047.0.15-0ubuntu0.16.04.1vulnerable
Ubuntuphp7.016.047.0.15-0ubuntu0.16.04.2vulnerable
Ubuntuphp7.016.047.0.15-0ubuntu0.16.04.4vulnerable
Ubuntuphp7.016.047.0.18-0ubuntu0.16.04.1vulnerable
Ubuntuphp7.016.047.0.22-0ubuntu0.16.04.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibonigsourcesid6.1.3-2not yet assignedNot reported[863318]
Debianlibonigsourceforky6.1.3-2not yet assignedNot reported[863318]
Debianlibonigsourcetrixie6.1.3-2not yet assignedNot reported[863318]
Debianlibonigsourcebookworm6.1.3-2not yet assignedNot reported[863318]
Alpinephp5apk3.45.6.31-r0Not reportedALPINE-CVE-2017-9229Not reported
Alpinephp5apk3.55.6.31-r0Not reportedALPINE-CVE-2017-9229Not reported
Ubuntulibonigdeb14.045.9.1-1ubuntu1.1Not reportedUBUNTU-CVE-2017-9229Not reported
Ubuntuphp5deb14.045.5.9+dfsg-1ubuntu4.22Not reportedUBUNTU-CVE-2017-9229Not reported
Ubuntulibonigdeb16.045.9.6-1ubuntu0.1Not reportedUBUNTU-CVE-2017-9229Not reported
Ubuntuphp7.0deb16.047.0.22-0ubuntu0.16.04.1Not reportedUBUNTU-CVE-2017-9229Not reported

[Debian bug #863318]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [libonig5]Fixed

    Source package: [libonig]

    Details (2)
    • 6.9.8-1 · amd64 · bookworm

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · bookworm; dsa · libonig · debian · 12

    • 6.9.8-1 · arm64 · bookworm

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · bookworm; dsa · libonig · debian · 12

  • Source package: [libonig]

    Details (2)
    • 6.9.8-1 · amd64 · bookworm

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · bookworm; dsa · libonig · debian · 12

    • 6.9.8-1 · arm64 · bookworm

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · bookworm; dsa · libonig · debian · 12

[Debian 13 (Trixie)]

  • [libonig5]Fixed

    Source package: [libonig]

    Details (2)
    • 6.9.9-1+b1 · amd64 · trixie

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · 13

    • 6.9.9-1+b1 · arm64 · trixie

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · 13

  • Source package: [libonig]

    Details (2)
    • 6.9.9-1+b1 · amd64 · trixie

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · 13

    • 6.9.9-1+b1 · arm64 · trixie

      Fixed · Fixed: 6.1.3-2

      dsa · libonig · debian · 13

Observed:

References