CVE catalog

CVE-2018-1000050

libstb: CVE-2018-1000050

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
1.84% · Oct 25, 2026

Sean Barrett stb_vorbis version 1.12 and earlier contains a Buffer Overflow vulnerability in All vorbis decoding paths. that can result in memory corruption, denial of service, comprised execution of host program. This attack appear to be exploitable via Victim must open a specially crafted Ogg Vorbis file. This vulnerability appears to have been fixed in 1.13.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibstbsid0.0~git20250907.fede005+ds-1not affected
Debianlibstbforky0.0~git20250907.fede005+ds-1not affected
Debianlibstbtrixie0.0~git20241109.5c20573+ds-1not affected
Debianlibstbbookworm0.0~git20220908.8b5f1f3+ds-1not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
DebianlibstbsourcesidNot affectedunimportantNot reportedNot reported
DebianlibstbsourceforkyNot affectedunimportantNot reportedNot reported
DebianlibstbsourcetrixieNot affectedunimportantNot reportedNot reported
DebianlibstbsourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [libstb0]Not affected

    Source package: [libstb]

    Details (2)
    • 0.0~git20220908.8b5f1f3+ds-1 · amd64 · bookworm

      Not affected

      dsa · libstb · debian · bookworm

    • 0.0~git20220908.8b5f1f3+ds-1 · arm64 · bookworm

      Not affected

      dsa · libstb · debian · bookworm

  • [libstb-dev]Not affected

    Source package: [libstb]

    Details (2)
    • 0.0~git20220908.8b5f1f3+ds-1 · amd64 · bookworm

      Not affected

      dsa · libstb · debian · bookworm

    • 0.0~git20220908.8b5f1f3+ds-1 · arm64 · bookworm

      Not affected

      dsa · libstb · debian · bookworm

Observed:

References