
CVE catalog
CVE-2018-1000079
rubygems: CVE-2018-1000079
- Severity
- Medium · CVSS 5.5
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.78% · Oct 25, 2026
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jruby | sid | 10.1.2.0+ds-1 | fixed |
| Debian | jruby | forky | 10.1.2.0+ds-1 | fixed |
| Debian | jruby | trixie | 9.4.8.0+ds-3 | fixed |
| Debian | jruby | bookworm | 9.3.9.0+ds-8 | fixed |
| Debian | rubygems | sid | 4.0.22-1 | fixed |
| Debian | rubygems | forky | 4.0.22-1 | fixed |
| Debian | rubygems | trixie | 3.6.7-2 | fixed |
| Debian | rubygems | bookworm | 3.3.15-2+deb12u1 | fixed |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.299-2 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.343-1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.343-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.353-1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.353-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2.1 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2.2 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2.4 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2.5 | vulnerable |
| Ubuntu | ruby2.0 | 14.04 | 2.0.0.484-1ubuntu2.6 | fixed |
| Ubuntu | jruby | pro | 1.5.6-5ubuntu1 | vulnerable |
| Ubuntu | jruby | pro | 1.5.6-6 | vulnerable |
| Ubuntu | jruby | pro | 1.5.6-7 | vulnerable |
| Ubuntu | jruby | pro | 1.5.6-9+deb8u2build0.14.04.1~esm2 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.0-1 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.0-2 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.0-4ubuntu2 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.0-4ubuntu3 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.0-5ubuntu1 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.1-2~16.04 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.1-2~16.04.2 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.1-2~16.04.4 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.1-2~16.04.5 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.1-2~16.04.6 | vulnerable |
| Ubuntu | ruby2.3 | 16.04 | 2.3.1-2~16.04.7 | fixed |
| Ubuntu | jruby | 16.04 | 1.7.21-2ubuntu4 | vulnerable |
| Ubuntu | jruby | 16.04 | 1.7.22-1ubuntu1 | vulnerable |
| Ubuntu | jruby | 18.04 | 9.1.13.0-1 | vulnerable |
| Ubuntu | jruby | 18.04 | 9.1.17.0-1~18.04 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jruby | source | sid | 9.1.17.0-1 | not yet assigned | Not reported | [895778] |
| Debian | jruby | source | forky | 9.1.17.0-1 | not yet assigned | Not reported | [895778] |
| Debian | jruby | source | trixie | 9.1.17.0-1 | not yet assigned | Not reported | [895778] |
| Debian | jruby | source | bookworm | 9.1.17.0-1 | not yet assigned | Not reported | [895778] |
| Debian | rubygems | source | sid | 3.2.0~rc.1-1 | not yet assigned | Not reported | Not reported |
| Debian | rubygems | source | forky | 3.2.0~rc.1-1 | not yet assigned | Not reported | Not reported |
| Debian | rubygems | source | trixie | 3.2.0~rc.1-1 | not yet assigned | Not reported | Not reported |
| Debian | rubygems | source | bookworm | 3.2.0~rc.1-1 | not yet assigned | Not reported | Not reported |
| Ubuntu | ruby2.0 | deb | 14.04 | 2.0.0.484-1ubuntu2.6 | Not reported | UBUNTU-CVE-2018-1000079 | Not reported |
| Ubuntu | ruby2.3 | deb | 16.04 | 2.3.1-2~16.04.7 | Not reported | UBUNTU-CVE-2018-1000079 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [bundler]Fixed
Source package: [rubygems]
Details (2)
2.3.15-2+deb12u1· all · bookwormFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12
2.3.15-2+deb12u1· all · bookwormFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12
- [jruby]Fixed
Details (2)
9.3.9.0+ds-8· all · bookwormFixed · Fixed:
9.1.17.0-1dsa · jruby · debian · bookworm; dsa · jruby · debian · 12
9.3.9.0+ds-8· all · bookwormFixed · Fixed:
9.1.17.0-1dsa · jruby · debian · bookworm; dsa · jruby · debian · 12
- [ruby-bundler]Fixed
Source package: [rubygems]
Details (2)
2.3.15-2+deb12u1· all · bookwormFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12
2.3.15-2+deb12u1· all · bookwormFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12
- [ruby-rubygems]Fixed
Source package: [rubygems]
Details (2)
3.3.15-2+deb12u1· all · bookwormFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12
3.3.15-2+deb12u1· all · bookwormFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · bookworm; dsa · rubygems · debian · 12
[Debian 13 (Trixie)]
- [bundler]Fixed
Source package: [rubygems]
Details (2)
2.6.7-2· all · trixieFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · 13
2.6.7-2· all · trixieFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · 13
- [jruby]Fixed
Details (2)
9.4.8.0+ds-3· all · trixieFixed · Fixed:
9.1.17.0-1dsa · jruby · debian · 13
9.4.8.0+ds-3· all · trixieFixed · Fixed:
9.1.17.0-1dsa · jruby · debian · 13
- [ruby-bundler]Fixed
Source package: [rubygems]
Details (2)
2.6.7-2· all · trixieFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · 13
2.6.7-2· all · trixieFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · 13
- [ruby-rubygems]Fixed
Source package: [rubygems]
Details (2)
3.6.7-2· all · trixieFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · 13
3.6.7-2· all · trixieFixed · Fixed:
3.2.0~rc.1-1dsa · rubygems · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2019_2028.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000079]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2018-1000079]
- [https://security-tracker.debian.org/tracker/CVE-2018-1000079]
- [https://security.access.redhat.com/data/csaf/v2/vex/2018/cve-2018-1000079.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]