CVE catalog

CVE-2018-1000119

UBUNTU-

[CVE catalog]

Sinatra rack-protection versions 1.5.4 and 2.0.0.rc3 and earlier contains a timing attack vulnerability in the CSRF token checking that can result in signatures can be exposed. This attack appear to be exploitable via network connectivity to the ruby application. This vulnerability appears to have been fixed in 1.5.5 and 2.0.0.

Severity
Medium · CVSS 5.9CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
Updated
Source
[NVD] · [CVE record]
EPSS
2.40% · Oct 27, 2026

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Ubuntu18.04ruby-rack-protection1.5.3-2UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Ubuntu18.04ruby-rack-protection1.5.3-2+deb9u1build0.18.04.1UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Ubuntu16.04ruby-rack-protection1.5.3-2UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Ubuntu16.04ruby-rack-protection1.5.3-2+deb9u1build0.16.04.1UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Debian9ruby-rack-protection1.5.3-2UnknownSource applicability is not established[DSA-4247-1]
Debian9ruby-rack-protection1.5.3-2+deb9u1UnknownSource applicability is not established[DSA-4247-1]
Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
Debian9ruby-rack-protection1.5.3-2UnknownSource applicability is not established[DSA-4247-1]
Debian9ruby-rack-protection1.5.3-2+deb9u1UnknownSource applicability is not established[DSA-4247-1]
Ubuntu16.04ruby-rack-protection1.5.3-2UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Ubuntu16.04ruby-rack-protection1.5.3-2+deb9u1build0.16.04.1UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Ubuntu18.04ruby-rack-protection1.5.3-2UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Ubuntu18.04ruby-rack-protection1.5.3-2+deb9u1build0.18.04.1UnknownSource applicability is not established[UBUNTU-CVE-2018-1000119]
Original provider fields
{
  "package_releases": [],
  "fixed_versions": [],
  "distribution_packages": [
    {
      "name": "ruby-rack-protection",
      "distro": "debian",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.5.3-2+deb9u1"
            }
          ]
        }
      ],
      "release": "9",
      "versions": [
        "1.5.3-2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/DSA-4247-1",
      "fixed_version": "1.5.3-2+deb9u1",
      "provider_source": "pypi",
      "provider_record_id": "DSA-4247-1",
      "provider_updated_at": "2026-03-09T02:11:27.479297Z",
      "applicability_unknown": true
    },
    {
      "name": "ruby-rack-protection",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.5.3-2+deb9u1build0.16.04.1"
            }
          ]
        }
      ],
      "release": "16.04",
      "versions": [
        "1.5.3-2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2018-1000119",
      "fixed_version": "1.5.3-2+deb9u1build0.16.04.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2018-1000119",
      "provider_updated_at": "2025-07-16T07:37:35.433621Z",
      "applicability_unknown": true
    },
    {
      "name": "ruby-rack-protection",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.5.3-2+deb9u1build0.18.04.1"
            }
          ]
        }
      ],
      "release": "18.04",
      "versions": [
        "1.5.3-2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2018-1000119",
      "fixed_version": "1.5.3-2+deb9u1build0.18.04.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2018-1000119",
      "provider_updated_at": "2025-07-16T07:37:35.433621Z",
      "applicability_unknown": true
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

Observed:

References