
CVE catalog
CVE-2018-1000127
memcached: CVE-2018-1000127
- Severity
- Medium · CVSS 6.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.27% · Oct 25, 2026
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | memcached | sid | 1.6.45-1 | fixed |
| Debian | memcached | forky | 1.6.45-1 | fixed |
| Debian | memcached | trixie | 1.6.38-1 | fixed |
| Debian | memcached | bookworm | 1.6.18-1 | fixed |
| Debian | memcached | bookworm-security | 1.6.18-1+deb12u1 | fixed |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu4 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu8 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9.1 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9.2 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9.3 | fixed |
| Ubuntu | memcached | 16.04 | 1.4.24-2ubuntu1 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-1ubuntu2 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1.2 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1.3 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1.4 | fixed |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu4 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu8 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9.1 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9.2 | vulnerable |
| Ubuntu | memcached | 14.04 | 1.4.14-0ubuntu9.3 | fixed |
| Ubuntu | memcached | 16.04 | 1.4.24-2ubuntu1 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-1ubuntu2 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1.2 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1.3 | vulnerable |
| Ubuntu | memcached | 16.04 | 1.4.25-2ubuntu1.4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | memcached | source | sid | 1.5.0-1 | not yet assigned | Not reported | [894404] |
| Debian | memcached | source | forky | 1.5.0-1 | not yet assigned | Not reported | [894404] |
| Debian | memcached | source | trixie | 1.5.0-1 | not yet assigned | Not reported | [894404] |
| Debian | memcached | source | bookworm | 1.5.0-1 | not yet assigned | Not reported | [894404] |
| Ubuntu | memcached | deb | 14.04 | 1.4.14-0ubuntu9.3 | Not reported | USN-3601-1 | Not reported |
| Ubuntu | memcached | deb | 16.04 | 1.4.25-2ubuntu1.4 | Not reported | USN-3601-1 | Not reported |
| Ubuntu | memcached | deb | 14.04 | 1.4.14-0ubuntu9.3 | Not reported | UBUNTU-CVE-2018-1000127 | Not reported |
| Ubuntu | memcached | deb | 16.04 | 1.4.25-2ubuntu1.4 | Not reported | UBUNTU-CVE-2018-1000127 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [memcached]Fixed
Details (2)
1.6.18-1· amd64 · bookwormFixed · Fixed:
1.5.0-1dsa · memcached · debian · bookworm; dsa · memcached · debian · 12
1.6.18-1· arm64 · bookwormFixed · Fixed:
1.5.0-1dsa · memcached · debian · bookworm; dsa · memcached · debian · 12
[Debian 13 (Trixie)]
- [memcached]Fixed
Details (2)
1.6.38-1· amd64 · trixieFixed · Fixed:
1.5.0-1dsa · memcached · debian · 13
1.6.38-1· arm64 · trixieFixed · Fixed:
1.5.0-1dsa · memcached · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_11045-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000127]
- [https://osv.dev/vulnerability/DLA-1329-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2018-1000127]
- [https://osv.dev/vulnerability/USN-3601-1]
- [https://security-tracker.debian.org/tracker/CVE-2018-1000127]
- [https://security.access.redhat.com/data/csaf/v2/vex/2018/cve-2018-1000127.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]