
CVE catalog
CVE-2018-11796
UBUNTU-CVE-2018-11796
- Severity
- High · CVSS 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 7.54% · Oct 25, 2026
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | tika | 16.04 | 1.5-2 | vulnerable |
| Ubuntu | tika | 16.04 | 1.5-3 | vulnerable |
| Ubuntu | tika | 16.04 | 1.5-4 | vulnerable |
| Ubuntu | tika | 16.04 | 1.5-4ubuntu0.1 | vulnerable |
| Ubuntu | tika | 18.04 | 1.5-5 | vulnerable |
| Ubuntu | tika | pro | 1.22-1 | vulnerable |
| Ubuntu | tika | pro | 1.22-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | tika | pro | 1.22-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | tika | pro | 1.22-1ubuntu0.1~esm3 | vulnerable |
| Ubuntu | tika | pro | 1.22-2 | vulnerable |
| Ubuntu | tika | pro | 1.22-2ubuntu0.22.04.1~esm1 | vulnerable |
| Ubuntu | tika | pro | 1.22-2+deb11u1build0.22.04.1 | vulnerable |
| Ubuntu | tika | pro | 1.22-2+deb11u1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | tika | pro | 1.22-2+deb11u1ubuntu0.1~esm2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: