CVE catalog

CVE-2018-12483

ocsinventory-server: CVE-2018-12483

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
3.22% · Oct 25, 2026

OCS Inventory 2.4.1 is prone to a remote command-execution vulnerability. Specifically, this issue occurs because the content of the ipdiscover_analyser rzo GET parameter is concatenated to a string used in an exec() call in the PHP code. Authentication is needed in order to exploit this vulnerability.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianocsinventory-serversid2.8.1+dfsg1+~2.11.1-3fixed
Debianocsinventory-serverbookworm2.8.1+dfsg1+~2.11.1-1fixed
Ubuntuocsinventory-server16.042.1.2-1vulnerable
Ubuntuocsinventory-server16.042.1.2-1ubuntu1vulnerable
Ubuntuocsinventory-server18.042.2+dfsg-0.1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianocsinventory-serversourcesid2.5+dfsg-1unimportantNot reported[905396]
Debianocsinventory-serversourcebookworm2.5+dfsg-1unimportantNot reported[905396]

[Debian bug #905396]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [ocsinventory-server]

    Details (2)
    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 2.5+dfsg-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 2.5+dfsg-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

  • Details (2)
    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 2.5+dfsg-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 2.5+dfsg-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

Observed:

References