
CVE catalog
CVE-2018-16854
UBUNTU-CVE-2018-16854
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 2.33% · Oct 25, 2026
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | moodle | pro | 2.7.9+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.10+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.11+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 2.7.11+dfsg-2 | vulnerable |
| Ubuntu | moodle | pro | 2.7.12+dfsg-1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1+esm1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1 | vulnerable |
| Ubuntu | moodle | pro | 3.0.3+dfsg-0ubuntu1+esm1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: