CVE catalog

CVE-2018-17567

jekyll: CVE-2018-17567

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.19% · Oct 25, 2026

Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the "include" key in the "_config.yml" file.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianjekyllsid4.4.1+dfsg-6fixed
Debianjekyllforky4.4.1+dfsg-6fixed
Debianjekylltrixie4.3.4+dfsg-1fixed
Debianjekyllbookworm4.3.1+dfsg-3+deb12u1fixed
Ubuntujekyll16.042.2.0+dfsg-2vulnerable
Ubuntujekyll16.043.0.1+dfsg-1vulnerable
Ubuntujekyll18.043.1.6+dfsg-3vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianjekyllsourcesid3.8.3+dfsg-3.1lowNot reported[909933]
Debianjekyllsourceforky3.8.3+dfsg-3.1lowNot reported[909933]
Debianjekyllsourcetrixie3.8.3+dfsg-3.1lowNot reported[909933]
Debianjekyllsourcebookworm3.8.3+dfsg-3.1lowNot reported[909933]

[Debian bug #909933]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [jekyll]Fixed
    Details (2)
    • 4.3.1+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 3.8.3+dfsg-3.1

      dsa · jekyll · debian · bookworm; dsa · jekyll · debian · 12

    • 4.3.1+dfsg-3+deb12u1 · all · bookworm

      Fixed · Fixed: 3.8.3+dfsg-3.1

      dsa · jekyll · debian · bookworm; dsa · jekyll · debian · 12

[Debian 13 (Trixie)]

  • [jekyll]Fixed
    Details (2)
    • 4.3.4+dfsg-1 · all · trixie

      Fixed · Fixed: 3.8.3+dfsg-3.1

      dsa · jekyll · debian · 13

    • 4.3.4+dfsg-1 · all · trixie

      Fixed · Fixed: 3.8.3+dfsg-3.1

      dsa · jekyll · debian · 13

Observed:

References