CVE catalog

CVE-2018-3717

node-connect: CVE-2018-3717

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.31% · Oct 25, 2026

connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-connectsid3.7.0+~3.4.38-1fixed
Debiannode-connectforky3.7.0+~3.4.38-1fixed
Debiannode-connecttrixie3.7.0+~3.4.35-1fixed
Debiannode-connectbookworm3.7.0+~3.4.35-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-connectsourcesid3.0.0-1not yet assignedNot reportedNot reported
Debiannode-connectsourceforky3.0.0-1not yet assignedNot reportedNot reported
Debiannode-connectsourcetrixie3.0.0-1not yet assignedNot reportedNot reported
Debiannode-connectsourcebookworm3.0.0-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 3.7.0+~3.4.35-1 · all · bookworm

      Fixed · Fixed: 3.0.0-1

      dsa · node-connect · debian · bookworm; dsa · node-connect · debian · 12

    • 3.7.0+~3.4.35-1 · all · bookworm

      Fixed · Fixed: 3.0.0-1

      dsa · node-connect · debian · bookworm; dsa · node-connect · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 3.7.0+~3.4.35-1 · all · trixie

      Fixed · Fixed: 3.0.0-1

      dsa · node-connect · debian · 13

    • 3.7.0+~3.4.35-1 · all · trixie

      Fixed · Fixed: 3.0.0-1

      dsa · node-connect · debian · 13

Observed:

References