CVE catalog

CVE-2018-6519

simplesamlphp: CVE-2018-6519

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.70% · Oct 25, 2026

The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiansimplesamlphpsid2.5.3.1-1fixed
Debiansimplesamlphpforky2.5.3.1-1fixed
Debiansimplesamlphpbookworm1.19.7-1+deb12u2fixed
Debiansimplesamlphpbookworm-security1.19.7-1+deb12u1fixed
Ubuntusimplesamlphppro1.13.2-1vulnerable
Ubuntusimplesamlphppro1.14.0-1vulnerable
Ubuntusimplesamlphppro1.14.0-1ubuntu2vulnerable
Ubuntusimplesamlphppro1.14.0-1ubuntu2+esm1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiansimplesamlphpsourcesid1.15.2-1not yet assignedNot reportedNot reported
Debiansimplesamlphpsourceforky1.15.2-1not yet assignedNot reportedNot reported
Debiansimplesamlphpsourcebookworm1.15.2-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (4)
    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.15.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.15.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.15.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.15.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

Observed:

References