CVE catalog

CVE-2018-7651

node-ssri: CVE-2018-7651

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
1.71% · Oct 25, 2026

index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-ssrisid9.0.1-6fixed
Debiannode-ssriforky9.0.1-6fixed
Debiannode-ssritrixie9.0.1-3fixed
Debiannode-ssribookworm9.0.1-2fixed
Ubuntunode-ssri18.045.0.0-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-ssrisourcesid5.2.4-1unimportantNot reported[891980]
Debiannode-ssrisourceforky5.2.4-1unimportantNot reported[891980]
Debiannode-ssrisourcetrixie5.2.4-1unimportantNot reported[891980]
Debiannode-ssrisourcebookworm5.2.4-1unimportantNot reported[891980]

[Debian bug #891980]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [node-ssri]Fixed
    Details (2)
    • 9.0.1-2 · all · bookworm

      Fixed · Fixed: 5.2.4-1

      dsa · node-ssri · debian · bookworm; dsa · node-ssri · debian · 12

    • 9.0.1-2 · all · bookworm

      Fixed · Fixed: 5.2.4-1

      dsa · node-ssri · debian · bookworm; dsa · node-ssri · debian · 12

[Debian 13 (Trixie)]

  • [node-ssri]Fixed
    Details (2)
    • 9.0.1-3 · all · trixie

      Fixed · Fixed: 5.2.4-1

      dsa · node-ssri · debian · 13

    • 9.0.1-3 · all · trixie

      Fixed · Fixed: 5.2.4-1

      dsa · node-ssri · debian · 13

Observed:

References