
CVE catalog
CVE-2019-10094
DEBIAN-
A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a StackOverflowError in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Apache Tika users should upgrade to 1.22 or later.
- Severity
- Medium · CVSS 5.5
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 2.46% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian11 | tika | 1.22-1 | UnknownSource applicability is not established | [DEBIAN-CVE-2019-10094] |
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian11 | tika | 1.22-1 | UnknownSource applicability is not established | [DEBIAN-CVE-2019-10094] |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "tika",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.22-1"
}
]
}
],
"release": "11",
"versions": [],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DEBIAN-CVE-2019-10094",
"fixed_version": "1.22-1",
"provider_source": "pypi",
"provider_record_id": "DEBIAN-CVE-2019-10094",
"provider_updated_at": "2026-08-29T07:00:14.614630793Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2019_2521-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2019-10094]
- [https://security.access.redhat.com/data/csaf/v2/vex/2019/cve-2019-10094.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]