CVE catalog

CVE-2019-1010161

libcrypt-jwt-perl: CVE-2019-1010161

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
1.10% · Oct 25, 2026

perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibcrypt-jwt-perlsid0.038-1not affected
Debianlibcrypt-jwt-perlforky0.038-1not affected
Debianlibcrypt-jwt-perltrixie0.037-1not affected
Debianlibcrypt-jwt-perlbookworm0.034-1not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibcrypt-jwt-perlsourcesidNot affectedunimportantNot reportedNot reported
Debianlibcrypt-jwt-perlsourceforkyNot affectedunimportantNot reportedNot reported
Debianlibcrypt-jwt-perlsourcetrixieNot affectedunimportantNot reportedNot reported
Debianlibcrypt-jwt-perlsourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [libcrypt-jwt-perl]Not affected
    Details (2)
    • 0.034-1 · all · bookworm

      Not affected

      dsa · libcrypt-jwt-perl · debian · bookworm

    • 0.034-1 · all · bookworm

      Not affected

      dsa · libcrypt-jwt-perl · debian · bookworm

Observed:

References